Bug #22502

In TCA (tt_content) the fe_groups field is not placed correctly under the Access Tab

Added by Peter Klein over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2010-04-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the TCA setup for the tt_content table, the "fe_group" field is not placed correctly/directly under the "Access" tab.

(It looks like it's under the Access Tab , but it really isn't, as it's placed using the "mainpalette" option.)

$TCA['tt_content']['ctrl']['mainpalette'] = 15;
$TCA['tt_content']['palettes']['15']['showitem'] = 'fe_group';

This makes the "fe_group" field appear as the LAST field in the BE tabs ,which is ok as long as the Access tab is the last one. But if an extension adds an extra Tab, then the "fe_group" field will be placed under that Tab, and not the Access Tab.

It looks like some "left overs" from before Tabs was introduced, as it might have made sence to place the "fe_group" field at the bottom of the page..

Wouldn't it be better to move the "fe_group" directly under the Access Tab?

(issue imported from #M14185)


Files

ext_tables.php.diff (413 Bytes) ext_tables.php.diff Administrator Admin, 2010-05-02 21:59
tbl_tt_content.php.diff (9.57 KB) tbl_tt_content.php.diff Administrator Admin, 2010-05-02 21:59
T3X_mainpalettetest-0_0_0-z-201005022323.t3x (1.49 KB) T3X_mainpalettetest-0_0_0-z-201005022323.t3x Administrator Admin, 2010-05-02 23:24
css_styled_content_ext_tables.php.diff (873 Bytes) css_styled_content_ext_tables.php.diff Administrator Admin, 2010-05-03 01:46
felogin_ext_tables.php.diff (633 Bytes) felogin_ext_tables.php.diff Administrator Admin, 2010-05-03 01:47
14185.diff (11.6 KB) 14185.diff Administrator Admin, 2010-05-03 03:22
#1

Updated by Chris topher over 11 years ago

Hi Peter,

thanks for your work to improve TYPO3!

You should now send your patch to the TYPO3 Core List.
There the open questions can be discussed and finally the best solution will be integrated.
Check out http://typo3.org/teams/core/core-mailinglist-rules/

#2

Updated by Peter Klein over 11 years ago

Attached dummy extension shows the problem when adding an extra Tab to tt_content.

#3

Updated by Lars Houmark over 11 years ago

Hi Peter,

I am currently testing this, as promised, in order to post it to the core list.

Everythings looks correct and is pretty-much a no-brainer, until I tested the 'table' content type, which, with your patch, does not show the fe_group field at all. Without the patch is shows the field on the last tab, no matter if extra tabs have been added by extension. Pretty strange actually.

I tried reading through the code and the ext_tables.php in general but could not figure out the reason. Maybe it's just me overlooking something because I am tired, feedback welcome ;)

I tested both in current trunk and the 4.3 branch latest SVN.

#4

Updated by Peter Klein over 11 years ago

Hi Lars.
You are correct about the "table" element (and also the "login" element) which apparently is overridden in other places.

I have attached 2 more patches which fixes the "table" (the css_styled_content patch) and the "login" problem (the felogin patch)

#5

Updated by Lars Houmark over 11 years ago

Attached is a final unified diff (14185.diff) against current trunk which includes all the other patches.

This patch is presented to the core list for reviews and hopefully a swift commit.

Aimed for both the current stable 4.3 branch and 4.4.

Thanks for your work Peter!

#6

Updated by Susanne Moog over 11 years ago

trunk rev 7543
4_3 rev 7544

Also available in: Atom PDF