Bug #22654

htmlArea RTE: RTE is greyed out and has no "styles" in page module QuickEdit

Added by Soren Malling over 9 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-06-01
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Using revision 7796 the RTE is "greyed" out and lost default css style

(issue imported from #M14567)

rte-editor-grey.png View (34.3 KB) Administrator Admin, 2010-06-01 12:01

rte-no-icons.png View (17.5 KB) Administrator Admin, 2010-06-15 21:27

rtehtmlarea_bugfix_14567_trunk.patch View (4.92 KB) Administrator Admin, 2010-06-16 02:43

History

#1 Updated by Stanislas Rolland over 9 years ago

In what browser?

I am not able to reproduce this issue. Try to clear all caches and the RTE cache.

#2 Updated by Soren Malling over 9 years ago

Found that the issue is related to the "Quick edit" function in the ("old") page module.

Issue found in FF 3.6.3 og Chrome 5

#3 Updated by Stanislas Rolland over 9 years ago

I am not able to reproduce this issue even within QuickEdit with current SVN trunk.

I note that the screenshot does not look like the skin of the new backend design included in revision 7796.

#4 Updated by Stanislas Rolland over 9 years ago

Could not reproduce with trunk revision 7836.

Please explain how to reproduce.

#5 Updated by Stanislas Rolland over 9 years ago

Is this still an issue with current trunk (revision 7928)?

#6 Updated by Soren Malling over 9 years ago

Sorry for my lack of response.

I will update my trunk tonight and get back with feedback!

#7 Updated by Soren Malling over 9 years ago

Updated trunk and did some work on recreating the problem; the editor is not shown properly, but now it's different that first screenshot:

With the old "page" module do the following:

- Create a new content element in ex. "right" - the RTE is shown correctly
- Click the page module and choose "Quick edit" and choose the element you just created
- The RTE isn't showing any icons (see "rte-no-icons.png" for example)

I'm using latest trunk

#8 Updated by Stanislas Rolland over 9 years ago

ok, thanks, now I can see. Now, the stylesheets of the RTE are empty, but the correct!

#9 Updated by Stanislas Rolland over 9 years ago

A backpath soup....

I think the attached patch will fix the issue and make the RTE correctly layed out in every context. Tested with page module, fe edit, advanced fr edit, fe, irre.

Thanks you for testing.

#10 Updated by Soren Malling over 9 years ago

Confirmed: The patch fixes the issue

#11 Updated by Stanislas Rolland over 9 years ago

Committed to SVN TYPO3core trunk (revision 7935).

#12 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF