Bug #22684

"User Settings" doesn't have CSS style

Added by Soren Malling about 10 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-05-19
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Sorry if double posting, couldn't seem to find this issue.

Using revision 7641 (and before) the "User Settings" module is lacking of CSS due to wrong path for the compressor made CSS styles.

From

typo3/ext/setup/mod/index.php

the css is tried to be reached by the address

<link rel="stylesheet" type="text/css" href="../typo3temp/compressor/element_csh-3d889fbcb8e616b940bdf33f8e49fbe2.css.gzip" media="all" />

Solution:
-------------

There should be a <base.. > or the links should be generated with a absolute url?

(issue imported from #M14437)

user-settings-no-css.png View (35.9 KB) Administrator Admin, 2010-05-19 19:45

History

#1 Updated by Chris topher about 10 years ago

I cannot reproduce this; for me the link to the CSS file is prepended correctly:
<link rel="stylesheet" type="text/css" href="../../../../typo3temp/compressor/merged-9b4d4b7c75a50b4dbd2f0fd9ef55ab67-5c7390d5e960611c81232fe1856c2328.css?1273927485" media="all" />

  • Did you clear your cache?
  • Does it work in the other modules?

#2 Updated by Steffen Gebert about 10 years ago

Caused by extbase_kickstarter, already reported there:
http://forge.typo3.org/issues/show/7615

#3 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF