Bug #22763

Icons missing in page tree for "Page contains" pages

Added by Soren Malling almost 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-05-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After choosing from "Page contains"

no icons is shown in the page tree for these pages.

screenshot shows for pages containing

"News"
"Website users"
The dam created folder

using latest checkput from trunk

(issue imported from #M14538)


Files

no-icons-pages.png (2.81 KB) no-icons-pages.png Administrator Admin, 2010-05-30 22:56
rfc-14538.diff (697 Bytes) rfc-14538.diff Administrator Admin, 2010-06-12 11:49

Related issues

Related to TYPO3 Core - Bug #22726: New Backend DesignClosedBenni Mack2010-05-27

Actions
Related to TYPO3 Core - Bug #22805: Sprite API: Missing icon "Edit whole record"ClosedSteffen Ritter2010-06-03

Actions
Related to TYPO3 Core - Bug #22963: Sprite API: Still a wrong iconClosedSusanne Moog2010-06-22

Actions
Related to TYPO3 Core - Bug #23067: Missing Sprite icon t3-icon-apps-pagetree is referencedClosedSteffen Kamper2010-07-01

Actions
#1

Updated by Steffen Ritter almost 11 years ago

this is indeed right, but since "contains" is not type - this is intended.

the uxw task was to clean up the look :)

the implementation has been very ugly in "old way" and since we are aiming to be cleaner in future I do not like to implement it in sprite-icon-for record sinc it would be a dirty hack to...

Clean way would be: register your own pagetype-with icon

#2

Updated by Soren Malling almost 11 years ago

That's a shame, especially when this article is fairly new and got some great feedback from readers.

http://buzz.typo3.org/people/steffen-kamper/article/new-icons-for-my-pages/

#3

Updated by Steffen Ritter almost 11 years ago

automatic fallback won't be possible anyways, be-skinning (what this belongs to) is not backwards compatible as of 4.4

talked to benni about it... what do you think about following solution:

"contains" overwrites "type", so that the type "contains_VALUE" would have been looked up in TCA[ctrl][typeicon_classes'] where you would register your own icon (from iconset or register own one via api-function)

#4

Updated by Steffen Ritter almost 11 years ago

patch pending in core list

#5

Updated by Steffen Kamper almost 11 years ago

Committed to trunk rev 7909

Also available in: Atom PDF