Bug #22813

Plugins are not loaded

Added by Michael Stucki about 11 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-06-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

There seems to be a bug in tslib_cObj::isClassAvailable() which keeps plugins from getting loaded.

The error happens with the "ml_links" extension for example. Just install it and watch the TS debug messages.

(issue imported from #M14623)


Files

bug_14623.diff (746 Bytes) bug_14623.diff Administrator Admin, 2010-06-04 17:29

Related issues

Related to TYPO3 Core - Feature #19510: Enable includeLibs also for USER and COA objectsClosedOliver Hader2008-10-27

Actions
#1

Updated by Michael Stucki about 11 years ago

The reason for the problem is that the magic in isClassAvailable() only happens if the TypoScript configuration is set. However, this is not the case when using a userFunc property, like in the example below (from EXT:ml_links):

tt_content.text.20.parseFunc.tags.link.typolink.userFunc = tx_mllinks_pi1->getFiletype

The problem can be solved by removing the check for any TypoScript configuration.

#2

Updated by Alexander Opitz about 8 years ago

  • Category deleted (Communication)
  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No response in over 3 month so closing this issue.

If you think this issue should be reopened, then write to the bugs mailing list.

Also available in: Atom PDF