Bug #22862

t3lib_utility_client is not working with php 5.2.0

Added by Franz Koch over 9 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-06-10
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

the preg_match_all pattern used to get the client information is using named subpatterns that are not compatible with php 5.2.0 but only php 5.2.2. Changing their spelling from '?<browser>' to '?P<browser>' does solve the issue.

(issue imported from #M14692)

t3lib_utitlity_client.diff View (727 Bytes) Administrator Admin, 2010-06-10 20:08


Related issues

Related to TYPO3 Core - Bug #22863: t3lib_utility_client uses pattern syntax supported only since PHP 5.2.2 Closed 2010-06-10

History

#1 Updated by Stanislas Rolland over 9 years ago

Committed to SVN TYPO3core trunk (revision 7871).

#2 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF