Bug #22921

Updates for taskcenter, sys_action, impexp

Added by Georg Ringer over 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-06-17
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

- Changes of the API how tasks are included
- CGL issues
- added manual
- removal of not needed files

(issue imported from #M14771)

14771_updates_manuals.rar (114 KB) Administrator Admin, 2010-06-17 22:57

14771_updates_impexp_v2.patch View (4.13 KB) Administrator Admin, 2010-06-17 22:57

14771_updates_sys-actions_v2.patch View (45.1 KB) Administrator Admin, 2010-06-17 22:58

14771_updates_taskcenter_v2.patch View (30.6 KB) Administrator Admin, 2010-06-17 22:58


Related issues

Related to TYPO3 Core - Feature #22363: Renewal of the taskcenter Closed 2010-03-31
Related to TYPO3 Core - Bug #53555: Faulty and superfluous code in import/export module Closed 2013-11-12

Associated revisions

Revision a4408f87 (diff)
Added by Oliver Hader about 6 years ago

[BUGFIX] Faulty and superfluous code in import/export module

There is faulty and superfluous code in import/export module:
  • ModuleFunctionController does not work at all, this points
    back to issue #22921 during TYPO3 4.4 development
  • ImportExportTask fetches thumbnail files from a (faulty)
    storage that are not used at all

Since the required class "mod_user_task" has been removed in
TYPO3 4.4, the module function component was broken since then.
Thus, it will be removed completely with this change.

Fixes: #53555
Releases: 6.2, 6.1, 6.0
Change-Id: I1cbdd967dc47ac2fcd256e7eefc756278822ad84
Reviewed-on: https://review.typo3.org/25302
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Oliver Klee
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Steffen Kamper over 9 years ago

Committed to trunk rev 8030
added manuals for taskcenter and sys_action in trunk rev 8031

#2 Updated by Oliver Hader over 6 years ago

  • Target version deleted (0)
  • Is Regression set to No

Applied in 4ca4a170d0e1947a1a40594687ff3ed79d6cc90f during TYPO3 4.4 development

Also available in: Atom PDF