Bug #53555

Faulty and superfluous code in import/export module

Added by Oliver Hader over 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Import/Export (T3D)
Target version:
-
Start date:
2013-11-12
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

There is faulty and superfluous code in import/export module:
  • ModuleFunctionController does not work at all: this points back to issue #22921 during TYPO3 4.4 development
  • ImportExportTask fetches thumbnail files from (faulty) storage that are not used at all

Related issues

Related to TYPO3 Core - Bug #22921: Updates for taskcenter, sys_action, impexp Closed 2010-06-17
Related to TYPO3 Core - Bug #23038: sysext taskcenter is missing class.mod_user_task.php (required from other extensions) Closed 2010-06-29

Associated revisions

Revision a4408f87 (diff)
Added by Oliver Hader over 6 years ago

[BUGFIX] Faulty and superfluous code in import/export module

There is faulty and superfluous code in import/export module:
  • ModuleFunctionController does not work at all, this points
    back to issue #22921 during TYPO3 4.4 development
  • ImportExportTask fetches thumbnail files from a (faulty)
    storage that are not used at all

Since the required class "mod_user_task" has been removed in
TYPO3 4.4, the module function component was broken since then.
Thus, it will be removed completely with this change.

Fixes: #53555
Releases: 6.2, 6.1, 6.0
Change-Id: I1cbdd967dc47ac2fcd256e7eefc756278822ad84
Reviewed-on: https://review.typo3.org/25302
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Oliver Klee
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25302

#2 Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25302

#3 Updated by Oliver Hader over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Anja Leichsenring over 4 years ago

  • Sprint Focus set to On Location Sprint

#5 Updated by Mathias Schreiber about 4 years ago

  • Sprint Focus deleted (On Location Sprint)

#6 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF