Bug #22973

Introduction Package: New Backend User created with uid=0

Added by Schmidt Timo almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-06-23
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I've installed the introduction package. New created backend users will be created with uid = 0. It seems that the auto_increment option is not set for be_users:uid

(issue imported from #M14836)


Related issues

Duplicated by TYPO3 Core - Bug #23004: Introduction Package: Adding a BE User makes the User Admin page close the session Closed 2010-06-25

History

#1 Updated by Georg Ringer almost 10 years ago

use the install tool > DB compare to set it

#2 Updated by Jo Hasenau almost 10 years ago

but this is just a workaround - I tested it and can confirm the behaviour: There are 4 BE users available but the new one gets uid 0 - and second try won't create any new user record, because the uid would still be 0 which is of course already taken. So the result is an error message while trying to save.

#3 Updated by Jo Hasenau almost 10 years ago

BTW: This doesn't happen with another install which is not based on the introduction package, so I guess it's not related to the 4.4 source but to the package only.

#4 Updated by Jo Hasenau almost 10 years ago

The bug seems to be in introduction.sql - uid is not set to autoincrement for the be_users table - I checked the rest and it seems to be OK

#5 Updated by Georg Ringer almost 10 years ago

as this project is hosted on forge > http://forge.typo3.org/issues/8465

please discuss this bug there, ticket is opend

#6 Updated by Mathias Schreiber almost 10 years ago

moved to forge

Also available in: Atom PDF