Bug #23010

Remove deprecated methods with deprecation log from core for 4.6

Added by Sebastian Michaelsen over 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-06-27
Due date:
% Done:

100%

TYPO3 Version:
4.4
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Beginning with 4.5 we can systematically remove old deprecated stuff from the core. As a first step I wanted to remove the obvious. This RFC removes all methods which:
  • are deprecated since 4.3 or earlier
  • have a deprecation log
  • are not in use anymore anywhere in the core

There are also methods which are deprecated but don't have deprecation log. IMHO we shouldn't simply remove them even if they were targeted for removal in 4.5. They should get deprecation logs (another RFC) and removal should be postponed to 4.7 for them.

Deprecated classes like gzip_encode should produce a deprecation log entry via constructor and also be removed in 4.7
(issue imported from #M14883)

14883_v1.diff View (58.4 KB) Administrator Admin, 2010-06-27 09:36

14883_v2.diff View (70.6 KB) Administrator Admin, 2010-06-28 09:01


Related issues

Related to TYPO3 Core - Task #24954: The Big Cleanup 4.6 Closed 2011-04-25

Associated revisions

Revision 92ed2089 (diff)
Added by Xavier Perseguers over 8 years ago

[TASK] Remove deprecated methods with deprecation log

Remove methods and files scheduled for removal since TYPO3 4.5.

Change-Id: I6ea863ae95f0433def4137cd4be1dc01ffc34bce
Resolves: #23010
Reviewed-on: http://review.typo3.org/1988
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader
Reviewed-by: Oliver Klee
Reviewed-by: Stefan Neufeind
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer

History

#1 Updated by Sebastian Michaelsen over 9 years ago

Noticed that the class gzip_encode already had a deprecation log in the constructor. So it can be safely removed.

#2 Updated by Sebastian Michaelsen about 9 years ago

Won't be done for 4.5 because of its LTS. Can be closed

#3 Updated by Chris topher about 9 years ago

Resolved, no change required (for now).

This has been postponed to 4.6, because 4.5 with Long Term Support should not break anything.

Thanks for the update!

#4 Updated by Ingo Renner about 9 years ago

opened a 4.6.0 version and set it as target.

#5 Updated by Mr. Hudson over 8 years ago

Patch set 1 of change I6ea863ae95f0433def4137cd4be1dc01ffc34bce has been pushed to the review server.
It is available at http://review.typo3.org/1988

#6 Updated by Xavier Perseguers over 8 years ago

  • Assignee set to Xavier Perseguers

#7 Updated by Xavier Perseguers over 8 years ago

  • Status changed from New to Under Review

#8 Updated by Mr. Hudson over 8 years ago

Patch set 2 of change I6ea863ae95f0433def4137cd4be1dc01ffc34bce has been pushed to the review server.
It is available at http://review.typo3.org/1988

#9 Updated by Xavier Perseguers over 8 years ago

  • Target version changed from 1081 to 1238

#10 Updated by Mr. Hudson over 8 years ago

Patch set 3 of change I6ea863ae95f0433def4137cd4be1dc01ffc34bce has been pushed to the review server.
It is available at http://review.typo3.org/1988

#11 Updated by Mr. Hudson over 8 years ago

Patch set 4 of change I6ea863ae95f0433def4137cd4be1dc01ffc34bce has been pushed to the review server.
It is available at http://review.typo3.org/1988

#12 Updated by Mr. Hudson over 8 years ago

Patch set 5 of change I6ea863ae95f0433def4137cd4be1dc01ffc34bce has been pushed to the review server.
It is available at http://review.typo3.org/1988

#13 Updated by Oliver Hader over 8 years ago

  • Target version changed from 1238 to 1281

#14 Updated by Mr. Hudson over 8 years ago

Patch set 6 of change I6ea863ae95f0433def4137cd4be1dc01ffc34bce has been pushed to the review server.
It is available at http://review.typo3.org/1988

#15 Updated by Mr. Hudson over 8 years ago

Patch set 7 of change I6ea863ae95f0433def4137cd4be1dc01ffc34bce has been pushed to the review server.
It is available at http://review.typo3.org/1988

#16 Updated by Xavier Perseguers over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Change has been successfully cherry-picked as 92ed20891b6daca779ea2e738578296c2779b515.

#17 Updated by Xavier Perseguers over 7 years ago

  • Status changed from Resolved to Closed

#18 Updated by Ernesto Baschny over 6 years ago

  • Target version deleted (1281)

Also available in: Atom PDF