Bug #23060

"View Item" does not resolve real MM Relations

Added by websedit AG over 10 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-06-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The overview "View Item" displays (Listview -> Display Information Icon) does not resolve real MM Relations correctly. It always shows the first entry of the related database no matter what.

This seems to be a bug in all Versions (tried 4.3 and 4.4)
(issue imported from #M14949)


Files

bug_14949.patch (3.71 KB) bug_14949.patch Administrator Admin, 2010-07-03 17:33
14949_v4-3.diff (3.72 KB) 14949_v4-3.diff Administrator Admin, 2010-08-22 19:04
14949_trunk.diff (4.42 KB) 14949_trunk.diff Administrator Admin, 2010-08-22 19:12

Related issues

Related to TYPO3 Core - Bug #22970: t3lib_BEfunc::getProcessedValue() did not handle TCA type inlineRejected2010-06-23

Actions
#1

Updated by Caspar Stuebs over 10 years ago

This seems to be related to http://bugs.typo3.org/view.php?id=14831

within show_item.php it is necessary to pass the record uid.

see patch in bug 14831

I have not testet MM-Relations yet ...

#2

Updated by Caspar Stuebs over 10 years ago

I have checked this problem for 4.4.0.

Within the show_item.php the uid has to be passed and in t3lib_BEfunc::getProcessedValue() there has to be a check, if the uid is passed.

see patch

#3

Updated by Francois Suter over 10 years ago

Updated patches for 4.3, 4.4 and 4.5. For 4.3 the initial patch did not apply cleanly. The 4.5 patch (backported to 4.4) contains additional CGL cleanup.

#4

Updated by Francois Suter over 10 years ago

Committed to:
- 4.3 in revision 8640
- 4.4 in revision 8641
- trunk in revision 8642

#5

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF