Bug #22970

t3lib_BEfunc::getProcessedValue() did not handle TCA type inline

Added by Caspar Stuebs over 9 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-06-23
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Within the function t3lib_BEfunc::getProcessedValue() there is no case which handle the TCA type inline, so typo3/show_item.php don't show these informations.

Furthermore the delimiter for the db-entries (types select and group) are inconsistence, one time it is a semicolon, the other times it is a comma.

I have added the handling for inline tables to the case of 'select'.
I also changed all delimiter to semicolon.

within show_item.php it is necessary to pass the record uid.
(issue imported from #M14831)

t3lib_befunc_getProcessedValue_show_item.patch View (2.72 KB) Administrator Admin, 2010-06-23 12:31

22970_v45_t3lib_befunc_getProcessedValue.patch View (1.83 KB) Caspar Stuebs, 2013-10-21 12:13

22970_v61_BackendUtility_getProcessedValue.patch View (1.96 KB) Caspar Stuebs, 2013-10-21 12:13


Related issues

Related to TYPO3 Core - Bug #23060: "View Item" does not resolve real MM Relations Closed 2010-06-30
Related to TYPO3 Core - Bug #58951: show_item does not properly resolve MM group items Closed 2014-05-20
Related to TYPO3 Core - Bug #52133: Display title of related record when using fields of type:inline as TCA label Closed 2013-09-19
Related to TYPO3 Core - Bug #59656: List mode doesn't show relation number, but tries to get record title from related table Closed 2014-06-18
Related to TYPO3 Core - Bug #59671: IRRE related child records are not listed (comma separated list) in list module Closed 2014-06-19

History

#1 Updated by Caspar Stuebs over 9 years ago

This seems to be related to http://bugs.typo3.org/view.php?id=14949

#2 Updated by Alexander Opitz almost 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5 or 6.1)?

As I understand the problem, this was fixed.

#3 Updated by Caspar Stuebs almost 6 years ago

Hi,

this Problem still exists in TYPO3 4.5 and 6.1

I have added new patches for both versions.

Greetings
Caspar

#4 Updated by Alexander Opitz almost 6 years ago

Ok thanks,

can you bring the patch against master into gerrit?

http://wiki.typo3.org/Contribution_Walkthrough_Tutorials

#5 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24930

#6 Updated by Caspar Stuebs over 5 years ago

This is related to #52133 and #59656

#7 Updated by Caspar Stuebs about 5 years ago

Some more related Tickets: #59671, #58951

#8 Updated by Wouter Wolters almost 5 years ago

  • Status changed from Under Review to Needs Feedback

Hi, in the meantime some patches are merged in this regard. Is this now fixed within TYPO3 CMS 7.0?

#9 Updated by Caspar Stuebs over 4 years ago

I do not know if it is fixed in 7.0, but it still has problems within 6.2. Every patch that was merged still solved a part of it and not the whole issue.

E.g. if I define a image field as element title, I still get the ids and not the titles of the fal elements.

#10 Updated by Anja Leichsenring over 4 years ago

I just tested with master, and for image fields I get the title in the inline field title, but no ID. So it seems this is fixed now.
If it is still an issue, could you please give me examples how to reproduce? A test extension, or maybe occurences in Core would be nice.

Thanks

#11 Updated by Gerrit Code Review over 4 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/24930

#12 Updated by Anja Leichsenring over 4 years ago

  • Status changed from Under Review to Rejected

open ever since, no feedback on request and I cannot reproduce. If you feel this is still an issue, just reopen the ticket.

Also available in: Atom PDF