Bug #23285

PATH_site not defined in typo3/thumbs.php

Added by Artur Cichosz about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-07-28
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We have used an include like this in one of the classes of an extension

require_once(PATH_tslib.'class.tslib_pibase.php');

This class was included inside the temporary config-cache files too. In general it worked fine but for the thumbs.php. During thumbnail generation the config-cache is loaded to. It failed because of the missng PATH_tslib constant.

I think it does no harm to define this constant inside thumbs.php even if it isn't needed there. It avoids such problems like ours.

(issue imported from #M15259)


Related issues

Related to TYPO3 Core - Bug #44017: typo3/thumbs.php causes invalid autoloader cache Closed 2012-12-14

History

#1 Updated by Mathias Schreiber about 9 years ago

thumbs.php is not intended to be used in FE thus adding FE constants might do harm if thumbs.php is being refactored.

Also available in: Atom PDF