Bug #23444

t3lib_error_Exception not available in some cases

Added by Stefan Galinski over 11 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-08-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
The current errorHandler tries to throw an t3lib_error_Exception if e.g. a PHP deprecation error is thrown. In this case the autoloading seems not to be available.

Solution:
Use a simple Exception instead of t3lib_error_Exception.

The following bug seems to be related to this issue:

http://bugs.typo3.org/view.php?id=13745
(issue imported from #M15550)


Files

15550_v1.diff (571 Bytes) 15550_v1.diff Administrator Admin, 2010-08-24 23:55

Related issues

Related to TYPO3 Core - Bug #22238: Fatal error: Class 't3lib_error_Exception' not foundClosedHelmut Hummel2010-03-04

Actions
Related to TYPO3 Core - Task #37335: Add a comment explaining the require_once calls in t3lib_error_ErrorHandlerClosedOliver Klee2012-05-20

Actions
Related to TYPO3 Core - Bug #36061: Remove obsolete require statements from ErrorHandlerClosed2012-04-14

Actions
Related to TYPO3 Core - Bug #36234: Uncaught TYPO3 Exception: Class t3lib_FlashMessage does not existClosed2012-04-17

Actions
#1

Updated by Steffen Kamper about 11 years ago

Committed to svn
4_3 rev 8751
4_4 rev 8752
trunk rev 8753

#2

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF