Bug #23705

sections in flexform check access to language 0 even if record is in another language

Added by Andreas Kiessling almost 9 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-10-11
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

This problem may be best seen in action with templavoila, but it is caused by the core handling of sections in flexforms.

When a section is defined in a flexform, the function getSingleField_typeFlex_draw in class t3lib_TCEforms checks if the user has access to the default language. This check is even done, when the record is totally unrelated to the default language, e.g. when you have a localized copy of an fce or a flexform in a simple extension record.

When a user has no access to the default language, he can not create a new entry in the section, but only edit the already existing.

The check should be changed if the user can edit the language of the current record, but probably only if the flexform is configured with langDisable = 1

(issue imported from #M15958)

15958_v1.patch View (847 Bytes) Administrator Admin, 2010-10-11 15:14

15958_v5.patch View (934 Bytes) Administrator Admin, 2011-01-10 12:03

History

#1 Updated by Andreas Kiessling almost 9 years ago

See attached patch.
langDisable can probably be ignored, because a new section is always independant of other languages

#2 Updated by Andreas Kiessling over 8 years ago

Attached v5.
Please test and vote in core list.

#3 Updated by Alexander Opitz about 5 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • Is Regression set to No

Hi Andreas,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.2.3)?

#4 Updated by Lukas Taferner about 5 years ago

Issue still exists in 4.5.34 and is very annoying. Patch works!

#5 Updated by Alexander Opitz over 4 years ago

  • Status changed from Needs Feedback to New

Issue exists in 6.2.
Can you update your patch?

#6 Updated by Christian Kuhn over 2 years ago

  • Status changed from New to Closed

the multi-lang feature with disableChildren=1 and friends has been dropped from core.

#7 Updated by Andreas Kiessling over 2 years ago

disableChildren and friends has nothing to do with that issue

The access check for lang 0 is still there: https://github.com/TYPO3/TYPO3.CMS/blob/38a1bc5dd7990b63e45c0419065cd02fe91187e9/typo3/sysext/backend/Classes/Form/Container/FlexFormSectionContainer.php#L50

So you can't restructure sections or add new elements without access to language 0. IMHO this is a bug or should be at least configurable.

Also available in: Atom PDF