Bug #23809

htmlArea RTE: Missing soft hyphen entity in CharacterMap

Added by Peter Kraume about 10 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-10-21
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Please add the soft hypen (­) to the CharacterMap

(issue imported from #M16087)

rtehtmlarea_bugfix_16087_typo3_4-4.patch View (2.48 KB) Administrator Admin, 2010-10-25 16:11

rtehtmlarea_bugfix_16087_trunk.patch View (2.48 KB) Administrator Admin, 2010-10-25 16:12


Related issues

Related to TYPO3 Core - Bug #25087: Soft hyphens: Editing impossible Closed 2011-02-18

History

#1 Updated by Peter Kraume about 10 years ago

The entity wasn't escaped by Mantis, so here it is again:
& shy;

#2 Updated by Stanislas Rolland about 10 years ago

Here it is! The patch adds the soft hyphen just before the n dash. Applies to current SVN trunk.

#3 Updated by Peter Kraume about 10 years ago

The patch works fine, but the entity isn't saved or shown when inserted into the RTE. Is there some more configuration needed?

#4 Updated by Stanislas Rolland about 10 years ago

Are you sure? This character is very, very shy. It is not shown in the RTE unless it is the last character on a line. This is the very definition of this character.

This is true in wysiwyg mode as well as in textmode because even the textarea is html, isn't it?

The rendering is the same on the frontend, but the "end of the line" may not be the same as in the RTE, depending on the width of the window.

Looking at the record in a utf-8 BE with phpmyAdmin, you can see a strange character at the position of the shy entity.

#5 Updated by Peter Kraume almost 10 years ago

You're right, my fault. Haven't tested it thoroughly enough. So +1 from me :)
Will this patch make it to the 4.4 branch as well?

And finally: which email address should I use for the PayPal donation?

#6 Updated by Stanislas Rolland almost 10 years ago

ok. Perhaps it may be viewed as a bug "Missing entity..." and moved to 4.4.

Many thanks for your sponsorship!

#7 Updated by Stanislas Rolland almost 10 years ago

Committed to SVN TYPO3core trunk (revision 9199) and branch TYPO3_4-4 (revision 9200).

#8 Updated by Peter Kraume almost 10 years ago

Thx a lot for getting this into 4.4! I've just send you your money via PayPal.

#9 Updated by Stanislas Rolland almost 10 years ago

Thanks again to both of you for your sponsorship!

#10 Updated by Ernesto Baschny over 7 years ago

  • Target version deleted (1088)

#11 Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF