Bug #24227

Deprecation Log blocks system

Added by Guido S. about 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-11-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

We've update a system to the newest T3 Version. This system uses many older extension. Because of this the deprecation log grows extremly fast.

The filesize of the depreaction log grows up to 2GB and then blocks the system. The problem is that the standard compilation of PHP allows only 2GB files. If this size is reached apache crashed.

It was very useful if the deprecation log would be better generated. Maybe every day or week a new file like in Linux systems?

(issue imported from #M16596)


Related issues

Related to Logging Project - Task #23489: Avoid duplicate entries in deprecation logRejected2010-09-01

Actions
Related to TYPO3 Core - Bug #24040: Handling deprecation logClosed2010-11-13

Actions
#1

Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • Is Regression set to No

Hi,

I don't think that logrotate should be implemented by the CMS. I would like to take the approach from #24040 to show the size of deprecation.log in the report. So can this issue closed?

#2

Updated by Guido S. over 6 years ago

Of course. We don't need duplicated issues ;-)

#3

Updated by Markus Klein over 6 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF