Bug #24439

TYPO3 fails to install on Windows due to faulty disposal of MCRYPT_DEV_URANDOM

Added by Oliver Hader over 10 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-12-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

<b>This was reported by direct mail by Jan Reilink (janreilink (at) vevida (dot) com):</b>

Typo3 (version 4.4.6) fails to install on Windows, due to improper
checking of MCRYPT_DEV_URANDOM capabilities. As you know, /dev/urandom
is not available on Windows. In the last week, two customers couldn't
install TYPO3 on their web site as a result.

I hacked my patch in the existence checking of the PHP-function
mcrypt_create_iv (also attached as .patch-file).

It could also be hacked in the class.t3lib_div.php file on/after line
1610, with a simple "elseif" line.

(issue imported from #M16871)


Files

class.t3lib_div.php.patch (1.28 KB) class.t3lib_div.php.patch Administrator Admin, 2010-12-29 16:36
class.t3lib_div.php.patch2 (557 Bytes) class.t3lib_div.php.patch2 Administrator Admin, 2010-12-29 17:12

Related issues

Is duplicate of TYPO3 Core - Bug #24410: Parameter for function "mcrypt_create_iv" not correctClosed2010-12-24

Actions
#1

Updated by Jan Reilink over 10 years ago

(thank you Oliver)

I created a new, and shorter, patch. The extra checks on TYPO3_OS are not necessary.

It was impossible to upload a file with the same name, nor could I delete the original file, so I renamed the second patch.

Regards

#2

Updated by Steffen Gebert over 10 years ago

resolved as duplicate of #24410

Could you please test the solution there? Thanks

#3

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF