Bug #24770

CSH in Flexforms of extbase exts broken

Added by Georg Ringer about 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2011-01-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

It seems that CSH in flexforms is broken again but only for extbase extensions. The reason is that the key for extbase based extensions is prepended with "settings.", so it looks like "settings.width" instead of "width".

CSH doesn't work with "settings.width" but with "width".
The line in CSH file looks like
-----------
<label index="settings.orderBy.description">Define the sorting field</label>
---------

of course the new API has been used and as said: it works without a dot

(issue imported from #M17265)


Files

17265_v2.diff (3.91 KB) 17265_v2.diff Administrator Admin, 2011-01-24 14:19

Related issues

Related to TYPO3 Core - Bug #24418: CSH in FlexForms does not work anymoreClosedFrancois Suter2010-12-26

Actions
#1

Updated by Ernesto Baschny about 10 years ago

Georg, could you come up with a solution? It sounds like something easy to fix? Would be important to have that in 4.5.0. Thanks!

#2

Updated by Francois Suter about 10 years ago

Committed v2 to trunk in revision 10311

Also available in: Atom PDF