Task #24900

Epic #24849: Upgrade Wizard Usability

"Version Compatibility" Upgrade Wizard should not be displayed if nothing changed (e.g. 4.4 > 4.5)

Added by Ernesto Baschny over 8 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2011-01-31
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

The "Version Compatibility" wizard will always show up, even if nothing was changed to the FE rendering. So the user is left with a dialog which is pretty confusing (see screenshot upgrade-wizard-compatVersion.png).

Solution: only call this wizard if there is there is something to do.
(issue imported from #M17415)

upgrade-wizard-compatVersion.png View (12.7 KB) Administrator Admin, 2011-01-31 10:47


Related issues

Related to TYPO3 Core - Bug #24834: Disable Upgade Wizard "Version Compatibility" if compat_version == TYPO3_version Closed 2011-01-26

Associated revisions

Revision cef71f88 (diff)
Added by Benni Mack over 4 years ago

[!!!][TASK] Remove option "compat_version"

The global option
$TYPO3_CONF_VARS[SYS][compat_version]
was introduced for having old frontend output
while upgrading an installation to a newer version.

For example, it was used for conditions within
CSS Styled Content before separate TS templates
for different versions were introduced.

The option mainly works within
GeneralUtility::compat_version, which
is used in several places.

In a normal installation the value equals the
constant TYPO3_branch.

The according update wizard for updating
the option is not needed anymore and is
removed without substitution.

Resolves: #24900
Releases: master
Change-Id: Id3fef21122ad92a9a5a9e90f60179b50d42b6a11
Reviewed-on: http://review.typo3.org/35684
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Chris topher almost 8 years ago

  • Target version changed from 4.6.0 to 4.6.1

#2 Updated by Chris topher almost 8 years ago

  • Target version changed from 4.6.1 to 4.6.2

#3 Updated by Xavier Perseguers over 7 years ago

  • Target version deleted (4.6.2)

#4 Updated by Ernesto Baschny almost 6 years ago

  • Tracker changed from Bug to Task
  • Category set to Install Tool
  • Parent task set to #24849

#5 Updated by Benni Mack over 4 years ago

Hey,

the problem here is that the version compatibility will always show up, because we need to raise the version compatibility in any case.

Maybe we can get rid of that option completely, as it is really not in use anymore.

#6 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35684

#7 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35684

#8 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35684

#9 Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35684

#10 Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35684

#11 Updated by Benni Mack over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Chris topher over 4 years ago

  • Target version set to 7.1 (Cleanup)

#13 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF