Bug #25060

config.debug = 1 triggers Quirks Mode in IE-Browser

Added by Christian Zenker about 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Communication
Target version:
-
Start date:
2011-02-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Enabling the debugger will put the debugging comment (<!-- Parsetime: ... -->) in front of any other output - even DocType declaration. This way Quirks Mode in Internet Explorer is triggered.

How to reproduce:
- set page.config.debug = 1 on a typical TypoScript setup
- verify that Quirks Mode is active by rendering a box with a width and height of 50px, border of 10px and some background color. You should see, that the colored box (without border) is actually just 30px high and wide. Standard mode would give you a box with the full 50px

Temporary Workaround:
- disable config.debug (at least for IE browsers)

Solution:
- render the debug output after the content as it was in TYPO3 4.4 and below. Patch is appended.

not present in TYPO3 4.4 and below
(issue imported from #M17618)


Files

debug-triggers-quirks-mode.diff (1.27 KB) debug-triggers-quirks-mode.diff Administrator Admin, 2011-02-16 16:48

Related issues

Is duplicate of TYPO3 Core - Bug #24913: Parsetime comment is inserted BEFORE the !doctype and the html tagClosedChristian Kuhn2011-02-01

Actions

No data to display

Also available in: Atom PDF