Project

General

Profile

Actions

Bug #25144

closed

Incorrect check for fe / be context in class.t3lib_tstemplate.php

Added by Rens Admiraal almost 13 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-02-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

class.t3lib_tstemplate.php uses if (is_object($GLOBALS['TSFE'])) to check for the frontend context, this should be if (TYPO3_MODE == 'FE')

(issue imported from #M17725)


Files

17725.diff (616 Bytes) 17725.diff Administrator Admin, 2011-02-23 19:36

Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #31139: better condition in versionOL of t3lib_tstemplateClosed2011-10-20

Actions
Actions #1

Updated by Dmitry Dulepov about 12 years ago

  • Status changed from New to Resolved
  • Target version deleted (0)

Already fixed in the current master (4.7).

Actions #2

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF