Bug #25149

Upgrading 4.5.0 to 4.5.1 breaks FE & BE ("lang extension not loaded")

Added by Andreas Mayer almost 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Communication
Target version:
-
Start date:
2011-02-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After reading the release notes, I tried to update 4.5.0 to 4.5.1 by changing the typo3_src symlink (as I always do)

However, I got a white page then and the PHP error log shows:
----------
#2 /opt/typo3/typo3_src-4.5.1/index.php(84): require('/opt/typo3/typo...')
#3 {main}
thrown in /opt/typo3/typo3_src-4.5.1/t3lib/class.t3lib_extmgm.php on line 142
[24-Feb-2011 00:17:30] PHP Fatal error: Uncaught exception 'BadFunctionCallException' with message 'TYPO3 Fatal Error: Extension key "lang" was NOT loaded!' in /opt/typo3/typo3_src-4.5.1/t3lib/class.t3lib_extmgm.php:142
Stack trace:
#0 /opt/typo3/typo3_src-4.5.1/t3lib/config_default.php(920): t3lib_extMgm::extPath('lang')
#1 /opt/typo3/typo3_src-4.5.1/typo3/sysext/cms/tslib/index_ts.php(128): require('/opt/typo3/typo...')
#2 /opt/typo3/typo3_src-4.5.1/index.php(84): require('/opt/typo3/typo...')
#3 {main}
thrown in /opt/typo3/typo3_src-4.5.1/t3lib/class.t3lib_extmgm.php on line 142
----------

I can login into the backend on /typo3 but then it says that LANG ext. is not installed, shows no page tree and so on. Any idea?

I didn't change anything, just change the typo4_src symlink from 4.5.0 to 4.5.1
(issue imported from #M17731)

#1

Updated by Ernesto Baschny almost 10 years ago

Thanks for the report.

Could you please check if you cleared all the typo3conf/temp* files after upgrading?

What's the content of the configuration:

$TYPO3_CONF_VARS['EXT']['requiredExt'] = '';

in your localconf.php?

#2

Updated by Philipp Idler almost 10 years ago

i confirm

upgraded from 4.5.0 to 4.5.1, upgrade wizard and compare database, deleted all l10n files in typo3temp and started translation handling.

backend and frontend in english (instead german) and error log says:
Core: Error handler (BE): PHP Warning: array_merge() [<a href='function.array-merge'>function.array-merge</a>]: Argument #2 is not an array in /home/typo3_src-4.5.1/typo3/sysext/em/classes/settings/class.tx_em_settings.php line 161

#3

Updated by Ernesto Baschny almost 10 years ago

Philipp, you "confirm", but this seems to be a totally unrelated bug. Could you file that issue on a new issue? It seems to be specific to the Extension Manager.

#4

Updated by Steffen Kamper almost 10 years ago

the warning is correct but this is not related to not finding the php classes.
(it just disapear when you save em extension configuration)

Please also tell us which OS and php version you use

#5

Updated by Philipp Idler almost 10 years ago

i think that both errors have the same source.
thats why i posted it here.
i'll open a new one

#6

Updated by Andreas Mayer almost 10 years ago

Yes, I have deleted all the typo3conf/temp* files after upgrading, didn't help.

I don't have $TYPO3_CONF_VARS['EXT']['requiredExt'] in my localconf.php, maybe this is the source of the error? Only have

$TYPO3_CONF_VARS['EXT']['extList'] = 'extbase,css_styled_content,tsconfig_help,context_help,extra_page_cm_options,impexp,sys_note,tstemplate,tstemplate_ceditor,tstemplate_info,tstemplate_objbrowser,tstemplate_analyzer,func_wizards,wizard_crpages,wizard_sortpages,lowlevel,install,belog,beuser,aboutmodules,setup,taskcenter,info_pagetsconfig,viewpage,rtehtmlarea,t3skin,a21glossary,icti_ext_filelinks,doc_indexed_search,indexed_search,info,perm,func,filelist,cshmanual,recycler,t3editor,reports,scheduler,fluid,version,workspaces,linkvalidator,rsaauth,realurl'; // Modified or inserted by TYPO3 Extension Manager.

I updated this Typo3 from 4.2.* -> 4.5.0 some time ago using the wizard.

#7

Updated by Ernesto Baschny almost 10 years ago

Are you using some kind of opcode-cache (like APC, XCACHE, eAccelerator)? If you do, please try restarting your webserver or deleting the opcode caching directory in between.

#8

Updated by Myroslav Holyak almost 10 years ago

Manual clearing of temp_* files in typo3conf solved this situation for me this morning

#9

Updated by swanage no-lastname-given almost 10 years ago

Clearing of temp_* files does not work for me.

f.e. with the settings:

mod.SHARED {
defaultLanguageFlag = en.gif
defaultLanguageLabel = english
}

the standard language flag shows a question mark in a red field.
Same happens regardless what language is set as default.

#10

Updated by Kai almost 10 years ago

I can confirm this problem. I got a white backend after upgrade from 4.5.0 to 4.5.1. I switched back to 4.5.0 (symlink) and then got a white frontend as well. Deleting the temp files did not help. After turning on error reporting in localconf I get:

<b>Fatal error</b>: Uncaught exception 'BadFunctionCallException' with message 'TYPO3 Fatal Error: Extension key "lang" was NOT loaded!' in /var/www/chi/typo3_src-4.5.0/t3lib/class.t3lib_extmgm.php:142
Stack trace:
#0 /var/www/chi/typo3_src-4.5.1/t3lib/config_default.php(920): t3lib_extMgm::extPath('lang')
#1 /var/www/chi/typo3_src-4.5.0/typo3/init.php(206): require('/var/www/chi/ty...')
#2 /var/www/chi/typo3_src-4.5.1/typo3/backend.php(28): require_once('/var/www/chi/ty...')
#3 {main}
thrown in <b>/var/www/chi/typo3_src-4.5.0/t3lib/class.t3lib_extmgm.php</b> on line <b>142</b><br />

The site is not working at all, so this is major issue.

Edit: After writing this note, I reloaded the page agin and it miraculously worked again (I did'nt do anything in between). So I pointed the symlink to 4.5.1 again and now the backend says:
Fatal error: Class 't3lib_extjs_ExtDirectApi' not found in /var/www/chi/typo3_src-4.5.1/t3lib/class.t3lib_div.php on line 5277

I looked through t3lib_div and "t3lib_extjs_ExtDirectApi" is not there (don't know if it is supposed to be there). So I switched back to 4.5.0 which now works.

#11

Updated by Ernesto Baschny almost 10 years ago

Kai:

If the "line is not there" it looks like the opcache is doing something wrong, and I suspect you are using Xcache, APC or eAccellerator.

Could you try to restart your webserver after the upgrade?

#12

Updated by Myroslav Holyak almost 10 years ago

with smart settings eAccelerator is checking for last modification time of file before get them from cache

#13

Updated by Kai almost 10 years ago

Sorry, I don't have root access to the server, so I can't restart it. The server is using apc. This is from phpinfo:
APC Support enabled
Version 3.1.3p1
MMAP Support Enabled
MMAP File Mask no value
Locking type pthread mutex Locks
Revision $Revision: 286798 $
Build Date Apr 18 2010 06:44:34

I don't know much about apc, but I tried to delete the cache with apc_clear_cache(), which worked (returned true).
I switched to 4.5.1 after that, but the backend had the same issue
(frontend worked fine). After a few minutes, the backend worked as well.
So I guess, it's some caching issue. But I doubt that clearing the apc cache
was the solution.

However, I couldn't log into the install tool in 4.5.1. So I switched back
to 4.5.0 where the install tool login is working. I got some warning e-mails saying:
"There has been an Install Tool login attempt at TYPO3 site 'xxx'.
The MD5 hash of the last 5 characters of the password tried was 'da6bf'".
My password (the one I entered in 4.5.1 and that works in 4.5.0) definitely
has a different MD5. That's a little strange...

#14

Updated by Ernesto Baschny almost 10 years ago

The problem with the install tool not working with PHP-APC is known and will be solved with the release of 4.5.2 tonight.

The other situation of the backend not working "for some time" and then suddenly working again is of course strange, but a very difficult issue to reproduce or to debug, because it doesn't happen to most of us developers. :(

So let's give the 4.5.2 a shot later on tonight and we'll see! ;)

#15

Updated by Kai almost 10 years ago

I'll try that. 4.5 otherwise is awesome by the way. Thanks for all the work!

#16

Updated by Ernesto Baschny almost 10 years ago

FYI, I've got this exact exception:

Fatal error: Uncaught exception 'BadFunctionCallException' with message 'TYPO3 Fatal Error: Extension key "lang" was NOT loaded!' in /var/www/chi/typo3_src-4.5.0/t3lib/class.t3lib_extmgm.php:142

In 4.5.0 when I had this line in localconf.php:

$TYPO3_CONF_VARS['EXT']['requiredExt'] = '';

The error doesn't occur in 4.5.1 and also in 4.5.2.

So please give it a try again, as soon as 4.5.2 is out and report here. Thanks!

#17

Updated by Kai almost 10 years ago

I installed 4.5.2. The "Uncaught exception 'BadFunctionCallException' " is gone, but know I get a fatal error again (as reported above in 0048312):

Fatal error: Class 't3lib_extjs_ExtDirectApi' not found in /var/www/chi/typo3_src-4.5.2/t3lib/class.t3lib_div.php on line 5277

This class exists in t3lib/extjs/class.t3lib_extjs_extdirectapi.php in my installation.

The call order in t3lib_div::makeInstance is:
ux_template
t3lib_PageRenderer
t3lib_cs
SC_index
t3lib_cs
tx_sv_loginformhook
tx_sv_loginformhook
tx_t3editor_hooks_tstemplateinfo
tx_t3editor_hooks_fileedit
t3lib_extjs_ExtDirectApi
Fatal error: Class 't3lib_extjs_ExtDirectApi' not found in /var/www/chi/typo3_src-4.5.2/t3lib/class.t3lib_div.php on line 5278

The class is included in core_autoload.php as:
't3lib_extjs_extdirectapi' => PATH_t3lib . 'extjs/class.t3lib_extjs_extdirectapi.php',

#18

Updated by Andreas Mayer over 9 years ago

Installed 4.5.2, updated symlink, deleted typo3conf/temp*, restarted Apache (needed for xcache to delete cached opcodes!), and it seems to work (FE as well as BE).

Thank you. - Original issue can be closed.

#19

Updated by Ernesto Baschny over 9 years ago

Works now

Also available in: Atom PDF