Bug #25212

Error 414 - "Request-URI Too Large" when saving file in extension manager (old version)

Added by RVVN no-lastname-given over 9 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2011-03-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

I get the following Apache error when I click on Save button :

"Request-URI Too Large

The requested URL's length exceeds the capacity limit for this server."

Look at the attachment to see the requested URL's length.
It seems that the whole file text is passed through GET even if the form data is submitted through POST.

No changes made on the web server configuration after updating our Typo3 sites from 4.3/4.4 to 4.5.
So file edition in these previous is still functional.
(issue imported from #M17812)


Files

#1

Updated by RVVN no-lastname-given over 9 years ago

I think the problem comes from HTML code of the file editing form.

< form action="mod.php?M=tools_em method="post"

See, the action attribute is missing an ending quote, thus the POST method seems to be bypassed and a too large GET request is raised.

Edit: missing quote is located @ line 1685, character 55

$outCode = '<form action="' . $this->script . ' method="post" name="editfileform">';

#2

Updated by Steffen Gebert over 9 years ago

in which file?

#3

Updated by RVVN no-lastname-given over 9 years ago

Sorry, missed paste ^^

=> typo3/sysext/em/classes/index.php

#4

Updated by Dirk Wildt over 9 years ago

Dear RVVN,
Thanks, that's the solution.

Kind regards
Dirk

#7

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF