Project

General

Profile

Actions

Bug #25329

closed

Task center - sys_action: Usergroups are not selected.

Added by Joannie Racine over 13 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-03-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When we edit a user already created, the usergroups that were already attributed to him are not selected in the list.

The problem is in the function getUsergroups() of the file : ../typo3/sysext/sys_action/task/class.tx_sysaction_task.php. For some situations the usergroups associated to a user are received in an array, but in this case, the usergroups are in a string.
I attached a patch that resolves the problem.

(issue imported from #M17954)


Files

bug_17954.diff (1.02 KB) bug_17954.diff Administrator Admin, 2011-03-15 20:18

Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #25700: Task center - sys_action: Password should not be required when editing BE-UserClosed2011-04-01

Actions
Related to TYPO3 Core - Bug #27440: Task center - sys_action: Prefix added to username over and over again when editing BE-UserClosed2011-06-14

Actions
Is duplicate of TYPO3 Core - Bug #36300: Sys Action > Create backend user does not load existing user correctlyClosed2012-04-18

Actions
Actions #1

Updated by Tobias Schmidt over 10 years ago

  • Target version deleted (0)

Can be closed as this issue is a duplicate of #36300

Actions #2

Updated by Wouter Wolters over 10 years ago

  • Status changed from New to Closed
  • Is Regression set to No
Actions

Also available in: Atom PDF