Bug #25370

BE-Login not possible with Firefox 4 and ySlow

Added by Michael Bakonyi over 9 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-03-22
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

With the RC from yesterday of Firefox 4 it seems to be impossible to login to the backend anymore. Error is "username/ pw incorrect". As this candidate might not change very much anymore regarding JS/AJAX this would lead to serious problems when people update next tuesday. So it might be worth to have a look at this issue although it's not clear yet if it's a FF- or T3-related problem.

Tested in 4.5.2 + 4.4.6, JS is activated
(issue imported from #M18005)

History

#1 Updated by Chris topher over 9 years ago

I just tested that with FF4 final and TYPO3 4.5.2 and it works for me.

#2 Updated by Michael Bakonyi over 9 years ago

Maybe it depends on the system – I work with a Mac here, and you?

#3 Updated by Chris topher over 9 years ago

I use Windows.

#4 Updated by Björn Pedersen over 9 years ago

Working here with FF4.0(linux) and trunk.

#5 Updated by Frederic Gaus over 9 years ago

Working with Firefox 4.0 on Mac

#6 Updated by Frederic Gaus over 9 years ago

Michael, could this be related to #22336? Did you try to switch of user-agent check?

#7 Updated by Steffen Gebert over 9 years ago

Michael, do you have ySlow enabled? I just had this issue on a site and it was definitely caused by ySlow. As soon as I disabled it, login worked.

We had this situation already some time ago with an older version of ySlow.

#8 Updated by Michael Bakonyi over 9 years ago

Steffen pointed me into the right direction: Firebug is the problem but only if it is docked within the browser-window. If FB is opened within its seperate window the problem doesn't appear. Thanks for your help, maybe other users will run into this problem aswell and hopefully they'll find this report.

#9 Updated by Steffen Gebert over 9 years ago

@Frederic Setting $TYPO3_CONF_VARS['BE']['lockHashKeyWords'] = '' and thus removing the user agent from the session calculation did not help.
So ySlow doesn't just modify the user agent randomly, but does some other weird things.

<b>For the moment: Deactivate the option "Autorun YSlow each time a web page is loaded"</b>. This will allow you to login.

#10 Updated by Michael Bakonyi almost 7 years ago

  • Target version deleted (0)

This ticket can be closed.

#11 Updated by Chris topher almost 7 years ago

  • Status changed from New to Closed

Closed as requested.

Also available in: Atom PDF