Bug #25650

Fatal error: Call to a member function push() with [SYS][useCachingFramework] = 1

Added by Bartosz Aninowski about 9 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
scheduler
Target version:
-
Start date:
2010-02-13
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If I set
[SYS][useCachingFramework] = 1
scheduler doesn't run correctly.

Typo3 throws following error (BE and cron)

Fatal error: Call to a member function push() on a non-object in /home/praca/source/typo3_src-4.3.1/typo3/sysext/cms/tslib/class.tslib_fe.php on line 600
Call Stack
  1. Time Memory Function Location
    1 0.0001 74216 {main}( ) ../mod.php:0
    2 0.0649 3869812 require( '/home/praca/source/typo3_src-4.3.1/typo3/sysext/scheduler/mod1/index.php' ) ../mod.php:51
    3 0.0714 3969612 tx_scheduler_Module->main( ) ../index.php:1540
    4 0.0714 3969932 tx_scheduler_Module->getModuleContent( ) ../index.php:152
    5 0.0715 3969932 tx_scheduler_Module->executeTasks( ) ../index.php:207
    6 0.0729 3974680 tx_scheduler->executeTask( ) ../index.php:876

(issue imported from #M13530)

History

#1 Updated by Francois Suter almost 9 years ago

I'm sorry, but I couldn't reproduce the issue. Could you post more details? In particular, what task were you trying to execute? It may be related to that specific task.

#2 Updated by Christian Kuhn almost 9 years ago

Resolved, unable to reproduce.

I'm unable to reproduce this, too. I assume this is a problem in some task that doesn't initialize FE properly. We have some tasks in the same scope, instantiating FE together with enabled caching framework and don't have such problems.

#3 Updated by Francois Suter over 6 years ago

  • Status changed from Resolved to Closed

#4 Updated by Michael Stucki over 5 years ago

  • Category set to scheduler

#5 Updated by Michael Stucki over 5 years ago

  • Project changed from Scheduler to TYPO3 Core
  • Category changed from scheduler to scheduler
  • Target version deleted (0)

Also available in: Atom PDF