Bug #26515

TCA definition is not available in upgrade wizards

Added by Oliver Hader over 8 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2011-04-29
Due date:
% Done:

100%

TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The global TCA definition is empty in some upgrade wizards. This was caused by a general clean-up to remove PHP global statements that did not seem to be required anymore. However, if PHP files get included inside a method or function accessing $TCA did not happen in a global context.


Related issues

Related to TYPO3 Core - Task #25334: Remove global declarations inside methods Closed 2011-03-16

Associated revisions

Revision 69fb8866 (diff)
Added by Steffen Gebert over 8 years ago

[BUGFIX] TCA definition is not available in upgrade wizards

The global TCA definition is empty in some upgrade wizards.
This was caused by a general clean-up to remove PHP global
statements that did not seem to be required anymore. However,
if PHP files get included inside a method or function accessing
$TCA did not happen in a global context.

Change-Id: I17df6b3caeda0ff2b5a7399c457ccebc57627882
Resolves: #26515
Reviewed-on: http://review.typo3.org/1809
Reviewed-by: Steffen Gebert
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Mr. Hudson over 8 years ago

Patch set 1 of change I17df6b3caeda0ff2b5a7399c457ccebc57627882 has been pushed to the review server.
It is available at http://review.typo3.org/1809

#2 Updated by Oliver Hader over 8 years ago

  • Status changed from New to Under Review

#3 Updated by Mr. Hudson over 8 years ago

Patch set 2 of change I17df6b3caeda0ff2b5a7399c457ccebc57627882 has been pushed to the review server.
It is available at http://review.typo3.org/1809

#4 Updated by Xavier Perseguers over 8 years ago

  • Target version changed from 1081 to 1238

#5 Updated by Steffen Gebert over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Xavier Perseguers over 7 years ago

  • Status changed from Resolved to Closed

#7 Updated by Ernesto Baschny over 6 years ago

  • Target version deleted (1238)

Also available in: Atom PDF