Bug #27258

list sort direction indicator is inconsistent

Added by Joh. Feustel over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-06-06
Due date:
% Done:

0%

TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Sorting arrows in various lists are inconsitent or missing

  • list module: direction is wrong, color is inconsistent and differs from new extJS grids.
  • completely missing file list module
Solution:
  • Add new sprite, copied from typo3/sysext/t3skin/icons/gfx/arrow(up|down).png
  • use sprite in list module and switch direction
  • add in file list module

Comments
The patch created new sprites status-status-sort-asc' and 'status-status-sort-desc' because its more a status than an action.
The icons could be impromed because it still differes from grid version (white on dark gray) and has no contrast in file list module (t3-row-header) but cannot be white because its in the .c-headLine row in db list module. But its still better than nothing and should not be the old red arrow in my eyes.
The patch also fixes a typo and corrects one line in phpdoc

See also unanswered question in #11127

27258.patch View (49.6 KB) Joh. Feustel, 2011-06-06 15:20

27258_no-css.patch View (3.03 KB) Joh. Feustel, 2011-06-06 16:05

History

#1 Updated by Joh. Feustel over 8 years ago

#2 Updated by Markus Klein over 8 years ago

Hi!
Can you please push a change request to review.typo3.org?

What typo do you mean and what phpdoc change does you patch include?
Sorry for not reading your patch, but it's extremely large and unclear.

What branches are affected?

#3 Updated by Joh. Feustel over 8 years ago

I will push it to gerrit today.
Patch was prepared for 4.6. I am not sure if this direction switch can be treated as a bugfix for 4.5 but I can push it to 4.5 also and let the release managers decide.
I just uploaded a patch file without the full css change. Should be clear now.

#4 Updated by Mr. Hudson over 8 years ago

Patch set 1 of change If6f8fcfbed8fe0d246257bcdbe2cf535750b42bb has been pushed to the review server.
It is available at http://review.typo3.org/2539

#5 Updated by Mr. Hudson over 8 years ago

Patch set 2 of change If6f8fcfbed8fe0d246257bcdbe2cf535750b42bb has been pushed to the review server.
It is available at http://review.typo3.org/2539

#6 Updated by Joh. Feustel over 7 years ago

Seems that this has been resolved in #11127 now

#7 Updated by Marcus Schwemer over 7 years ago

@ Joh.

Can you abandon your change on review.typo3.org and close this issue here?

Thanks
Marcus

#8 Updated by Joh. Feustel over 7 years ago

change abandoned.
Seems that I am not able to change the status to closed.

#9 Updated by Susanne Moog over 7 years ago

  • Status changed from New to Closed

Also available in: Atom PDF