Bug #28099

Fatal error if setDBinit not set in localconf.php

Added by Helmut Hummel over 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Must have
Category:
Backend API
Target version:
-
Start date:
2011-07-12
Due date:
% Done:

100%

TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
After the t3lib_div refactoring done in #28026 a fatal error is thrown, because the class "t3lib_utility_VersionNumber" does not exist. This happens if $TYPO3_CONF_VARS['BE']['forceCharset'] or $TYPO3_CONF_VARS['SYS']['setDBinit'] are not set in localconf.php

Solution:
Initialize autoloader earlier in the bootstrap


Related issues

Related to TYPO3 Core - Task #28026: Remove deprecated usages of intInRange, int_from_version, intval_positive Closed 2011-07-09
Duplicates TYPO3 Core - Bug #28098: call to t3lib_div::compat_version() in config_default.php breaks the system Closed 2011-07-11

Associated revisions

Revision bc3783ca (diff)
Added by Helmut Hummel over 8 years ago

[BUGFIX] Initialize autoloader earlier in the bootstrap

Because of the refactoring of t3lib_div the autoloader is needed
earlier in the bootstrap.
Move it right after the inclusion of localconf.php

Resolves: #28099
Relates: #28026
Releases: 4.6

Change-Id: Ie818c9b791a421c9f85705a75bf50be4068fbdd7
Reviewed-on: http://review.typo3.org/3265
Reviewed-by: Tolleiv Nietsch
Tested-by: Tolleiv Nietsch
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind
Reviewed-by: Xavier Perseguers
Tested-by: Xavier Perseguers

History

#1 Updated by Mr. Hudson over 8 years ago

Patch set 1 of change Ie818c9b791a421c9f85705a75bf50be4068fbdd7 has been pushed to the review server.
It is available at http://review.typo3.org/3265

#2 Updated by Xavier Perseguers over 8 years ago

  • Status changed from New to Resolved
  • Assignee set to Xavier Perseguers
  • % Done changed from 0 to 100

Change has been successfully cherry-picked as bc3783ca260555f13080737c1af526f9e495d09e.

#3 Updated by Xavier Perseguers about 8 years ago

  • Status changed from Resolved to Closed

#4 Updated by Ernesto Baschny almost 7 years ago

  • Target version deleted (1281)

Also available in: Atom PDF