Bug #28105

Typo3 Installation removes table

Added by Christopher Seidel over 8 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
scheduler
Target version:
-
Start date:
2011-07-12
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

i found a problem with the Scheduler and the Installation Tool of Typo3 Version 4.5.3

The Installation Tool suggests me to delete the table of the database:

Removing tables (rename with prefix)

(EXT) ALTER TABLE tx_scheduler_task RENAME zzz_deleted_tx_scheduler_task;
Records in table: 4

I think this is a bug, but im not sure if it comes from the Scheduler or the Installation Tool.

Regards
Christopher

History

#1 Updated by Chris topher over 8 years ago

Do you have scheduler installed?

When it is uninstalled, the table will be proposed for deletion.

#2 Updated by Christopher Seidel over 8 years ago

No its installed and i use four schedules. I was wondering why the scheduler list was empty after i made the cleanup. Then i saw that installation tool always wants to rename the table ... :/

#3 Updated by Chris topher over 8 years ago

I have just checked that with master and the table is not proposed for deletion for me.

A guess: Do you have strange values for $TYPO3_CONF_VARS['EXT']['extList'] = '...' in localconf.php?
The variable name and the value must both only have single quotes (no double quotes) and there should only be one line with the variable name $TYPO3_CONF_VARS['EXT']['extList'] below the "Install-Tool-will-edit-everything-below"-token.

#4 Updated by Christian Kuhn over 8 years ago

No feedback ...

I think we should close this issue since we are unable to reproduce. I guess the extension was either un installed and the table removed meanwhile, or there is funny code in localconf.php that triggeres this.

This issue can not be tackled any further without help of the submitter and it is probably not an issue of the scheduler anyway.

#5 Updated by Francois Suter over 8 years ago

  • Status changed from New to Rejected

Agreed.

#6 Updated by Michael Stucki about 6 years ago

  • Category set to scheduler

#7 Updated by Michael Stucki about 6 years ago

  • Project changed from Scheduler to TYPO3 Core
  • Category changed from scheduler to scheduler

Also available in: Atom PDF