Bug #28526

Using slide = -1 with stdWrap options on pidInList with CONTENT runs into an endless loop

Added by Marc Bastian Heinrichs about 11 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2011-07-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Test-Example:

lib.content.right = COA
lib.content.right {
10 < styles.content.getRight
10.select.pidInList.data = TSFE:id
10.slide = -1
}

Because the stdWrap parameters are not unset after the first run, the same parentPids are
selected for TSFE:id via getSlidePids() over and over again till the max execution time is reached.


Files

28526.patch (1.11 KB) 28526.patch Marc Bastian Heinrichs, 2011-07-27 21:42
#2

Updated by Steffen Gebert about 11 years ago

Hi Marc,

thanks for the report. Sounds reasonable. Could you please submit the patch to the review system?

See the wiki for a guide or just join the upcoming bug weekend.

Thanks for contributing!
Steffen

#3

Updated by Steffen Gebert about 11 years ago

  • Complexity set to easy
#4

Updated by Marc Bastian Heinrichs about 11 years ago

Hi Steffen,

thanks for the report. Sounds reasonable. Could you please submit the patch to the review system?

Jep, I could submit it. But will take some time, because I have a big launch on Tuesday.

master, 4.5 and 4.4?

Bastian

#5

Updated by Steffen Gebert about 11 years ago

Hi Bastian,

fine, thanks so far. Start with master, when it's merged, please submit for 4.4 and 4.5

#6

Updated by Gerrit Code Review over 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7033

#7

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7033

#8

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/8943

#9

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/8944

#10

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-4 has been pushed to the review server.
It is available at http://review.typo3.org/8945

#11

Updated by Marc Bastian Heinrichs over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#12

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF