Bug #28578

userdefined page-icon are not loaded in pagetree

Added by Michael Stein over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2011-07-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I do:
t3lib_SpriteManager::addTcaTypeIcon('pages', 'contains-myext', '../typo3conf/myext/res/icons/calendar.gif');
$TCA['pages']['columns']['module']['config']['items'][6][0] = 'Kalender';
$TCA['pages']['columns']['module']['config']['items'][6][1] = 'calendar';
$TCA['pages']['columns']['module']['config']['items'][6][2] = t3lib_extMgm::extRelPath($_EXTKEY) . 'res/icons/calendar.gif';

It is well loaded in the listview and in the pageproperty-frame etc.

The icon is NOT loaded in the pagetree.
The icon-span has the correct class:
<span class="t3-icon t3-icon-tcarecords t3-icon-tcarecords-pages t3-icon-pages-contains-calendar" id="ext-gen1075" qtip="id=127"> </span>

in the merged css-file is:
.t3-icon-pages-contains-calendar{background-position:0px 0px !important;background-image:url('../../typo3conf/ext/klicksafe/res/icons/calendar.gif') !important}

which is one '../' to much


Related issues

Is duplicate of TYPO3 Core - Bug #23932: In a sysfolder, the field Contains Plugin does not show the correct iconClosed2010-11-03

Actions
#1

Updated by Steffen Gebert over 10 years ago

  • Category changed from Backend User Interface to Backend API
  • Status changed from New to Needs Feedback
  • Assignee deleted (Oliver Hader)
  • Priority changed from Must have to Should have
  • Target version deleted (4.5.5)

Thanks for your report, Michael.

Please do not add target versions yourself and please also do not assign a bug to somebody (unfortunately, it's a limitation of redmin that you can do this).

Please set

$TYPO_CONF_VARS['BE']['debug'] = 1

to see, whether it's really a limitation of the merging and if it works without that.

Thanks for your feedback!
Steffen

#2

Updated by Steffen Gebert over 10 years ago

  • Status changed from Needs Feedback to Closed

Michael created a duplicate here. As some more information is contained there, I close this one now.

#3

Updated by Steffen Gebert over 10 years ago

  • Status changed from Closed to New

Oh, sorry.. this should not have been closed!

#4

Updated by Steffen Gebert over 10 years ago

Stefan and SteffenR, could you please have a look? It's a merging point, where your work comes together :)

Thanks

#5

Updated by Michael Stein over 10 years ago

Sorry, I could't reproduce my problem.
Maybe I was running 3 hours in a cache-compressor-tiredness-typing-error-loop

Sorry for report-bug.

Please close this thing.

Michael

#6

Updated by Steffen Gebert over 10 years ago

  • Status changed from New to Closed

Thanks for providing feedback!

Also available in: Atom PDF