Bug #28593

Upgrade Wizard "Deprecated RTE properties in Page TS Config" fails if no deprecated properties are used at all.

Added by Philipp Gampe almost 8 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2011-07-30
Due date:
% Done:

0%

TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Related issues

Related to TYPO3 Core - Feature #28325: htmlArea RTE: Deprecate/restructure various RTE configuration properties Closed 2011-07-20

Associated revisions

Revision 007b98f7 (diff)
Added by Stanislas Rolland almost 8 years ago

[BUGFIX] Upgrade wizard fails if no deprecated properties are found

Upgrade Wizard "Deprecated RTE properties in Page TS Config" fails
when no deprecated properties are used at all.

Make it a success, but keep the information message.

Change-Id: I0e0919cc02536a12d84da3d37cea64afe3af12e3
Resolves: #28593
Releases: 4.6
Reviewed-on: http://review.typo3.org/3908
Reviewed-by: Stanislas Rolland
Tested-by: Stanislas Rolland

History

#1 Updated by Stanislas Rolland almost 8 years ago

  • Category changed from Install Tool to RTE (rtehtmlarea + ckeditor)
  • Assignee set to Stanislas Rolland
  • Target version set to 4.6.0-beta1

#2 Updated by Stanislas Rolland almost 8 years ago

What do you mean by "fails"?

#3 Updated by Philipp Gampe almost 8 years ago

That what it says if I run it.

Deprecated RTE properties in Page TS Config 
 Update FAILED! 

No deprecated Page TS Config properties were found on page records.

Note that Page TS Config may be included from external files. These were not updated by this wizard. If required, the update will need to be done manually.

I think it should not be shown then.

#4 Updated by Stanislas Rolland almost 8 years ago

Will make it a success, but will keep the information maessage.

#5 Updated by Mr. Hudson almost 8 years ago

Patch set 1 of change I0e0919cc02536a12d84da3d37cea64afe3af12e3 has been pushed to the review server.
It is available at http://review.typo3.org/3908

#6 Updated by Stanislas Rolland almost 8 years ago

  • Status changed from New to Under Review

#7 Updated by Stanislas Rolland almost 8 years ago

  • Status changed from Under Review to Resolved

#8 Updated by Philipp Gampe almost 8 years ago

Works now.

What about saving the run state to localconf.php like it is done with install sysext wizard? That way, the wizard would only show up once.

#9 Updated by Stanislas Rolland almost 8 years ago

  • Status changed from Resolved to Under Review

#10 Updated by Stanislas Rolland almost 8 years ago

Philipp Gampe wrote:

What about saving the run state to localconf.php like it is done with install sysext wizard? That way, the wizard would only show up once.

Since deprecated Page TSconfig properties may be found in BE group and BE user records, as well as in external files not searched, nor updated by the wizard, I would like to keep showing the notice and list of deprecated properties until at least release 4.7.

#11 Updated by Stanislas Rolland almost 8 years ago

  • Status changed from Under Review to Resolved

#12 Updated by Xavier Perseguers over 7 years ago

  • Status changed from Resolved to Closed

#13 Updated by Ernesto Baschny about 6 years ago

  • Target version deleted (4.6.0-beta1)

Also available in: Atom PDF