Bug #28910

select_key should be in "Plugin" tab

Added by Sigfried Arnold over 9 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-08-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

I'm aware that select_key gets replaced by flexforms more and more - but if you use an extension which still uses select_key, there is no reason for hiding it in the "Behaviour" tab.

#18595 is somewhat related to that.


Related issues

Related to TYPO3 Core - Feature #17568: Hook request for Web>Page plugin "additional info" displayClosedErnesto Baschny2007-08-30

Actions
Related to TYPO3 Core - Feature #18595: Apply link wizard for folder selection to tt_content, CType uploadsClosed2008-04-09

Actions
#1

Updated by Sigfried Arnold over 9 years ago

Also #17568 is related - it's mentioned, that it will be in the 4.2 Core - but not how exactly.

#2

Updated by Jigal van Hemert over 9 years ago

#17568 implements a hook to display something else than "CODE:..." in the columns view of the Page module. That issue not about the way the different fields are displayed when editing a content element.
See discussion in Core list: http://lists.typo3.org/pipermail/typo3-team-core/2007-August/008872.html

#3

Updated by Jigal van Hemert over 9 years ago

  • Status changed from New to Needs Feedback

The field "select_key" is a (very old) method to determine what the plug-in does; in other words, its behaviour.

The forms are now organised that tabs contain a group of fields with related functionalities. Also the most frequently used fields (as in used by editors) are easy to find.
As you already mention the select_key field is seldom used and mostly used by site integrators / admins.

Where would you like to 'hide' this field?

#4

Updated by Sigfried Arnold over 9 years ago

I'd position it right below the 'list_type' field - just above the flexform.

Currently, if you add a plugin, you need to switch to the "Plugin" tab, select the plugin, switch to "Behaviour" and change the select_key. If you use a flexform enabled plugin, you don't need to switch to the behaviour tab - it's all right there.

Since the pi_flexform somewhat replaces select_key, it seems to be obvious that both are located on the same spot.

#5

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to New
#6

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35495

#7

Updated by Benni Mack almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#8

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF