Bug #31246

Internal extension information is not updated properly

Added by Oliver Hader about 8 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Extension Manager
Target version:
Start date:
2011-10-24
Due date:
% Done:

100%

TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

tx_em_Tools::refreshGlobalExtList() is triggered on installing extensions. However the current implementation is wrong (early return) and does not consider $TYPO3_CONF_VARS.

This misbehavior also prevents the Introduction Package to correctly install accordant cf_* tables of workspaces and extbase, since the information in $TYPO3_CONF_VARS is not available globally.


Related issues

Related to TYPO3 Core - Bug #30862: Install Tool throws database errors in Upgrade Wizard, because caching framework tables are still missing Closed 2011-10-12

Associated revisions

Revision fa08e0f4 (diff)
Added by Oliver Hader about 8 years ago

[BUGFIX] Internal extension information is not updated properly

tx_em_Tools::refreshGlobalExtList() is triggered on installing
extensions. However the current implementation is wrong (early
return) and does not consider $TYPO3_CONF_VARS.

This misbehavior also prevents the Introduction Package to
correctly install accordant cf_* tables of workspaces and
extbase, since the information in $TYPO3_CONF_VARS is not
available globally.

Change-Id: I3a1b8ea9d2da40a52d9838ac8b1fe9551b6dfed8
Fixes: #31246
Reviewed-on: http://review.typo3.org/6270
Reviewed-by: Tolleiv Nietsch
Tested-by: Tolleiv Nietsch
Reviewed-by: Steffen Gebert
Tested-by: Steffen Gebert

History

#1 Updated by Mr. Hudson about 8 years ago

  • Status changed from New to Under Review

Patch set 1 of change I3a1b8ea9d2da40a52d9838ac8b1fe9551b6dfed8 has been pushed to the review server.
It is available at http://review.typo3.org/6270

#2 Updated by Mr. Hudson about 8 years ago

Patch set 2 of change I3a1b8ea9d2da40a52d9838ac8b1fe9551b6dfed8 has been pushed to the review server.
It is available at http://review.typo3.org/6270

#3 Updated by Mr. Hudson about 8 years ago

Patch set 3 of change I3a1b8ea9d2da40a52d9838ac8b1fe9551b6dfed8 has been pushed to the review server.
It is available at http://review.typo3.org/6270

#4 Updated by Mr. Hudson about 8 years ago

Patch set 4 of change I3a1b8ea9d2da40a52d9838ac8b1fe9551b6dfed8 has been pushed to the review server.
It is available at http://review.typo3.org/6270

#5 Updated by Mr. Hudson about 8 years ago

Patch set 5 of change I3a1b8ea9d2da40a52d9838ac8b1fe9551b6dfed8 has been pushed to the review server.
It is available at http://review.typo3.org/6270

#6 Updated by Oliver Hader about 8 years ago

  • Assignee set to Oliver Hader
  • Priority changed from Should have to Must have

#7 Updated by Oliver Hader about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF