Project

General

Profile

Actions

Bug #31404

closed

session.auto_start flag not checked correctly

Added by Jochen Weiland over 12 years ago. Updated about 12 years ago.

Status:
Closed
Priority:
Must have
Category:
Install Tool
Target version:
Start date:
2011-10-29
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

When loading, the install tool checks the status of the PHP flag session.auto_start and stops with an error message if auto_start is enabled.

The check is done in sysext/install/mod/class.tx_install_session.php:

if (ini_get('session.auto_start')) {

  (display error message and throw runtime exception)

}

This works as long as ini_get('session.auto_start') returns an empty string.

We found that when running PHP in FCGI/FPM mode, the return value is the string "Off" and thus trowing the exception even if auto_start is not set.

In our PHP CGI configuration it works, since an empty string is returned instead of "Off".

Tested with PHP 5.3.8

Our temporary solution was this patch:

if (ini_get('session.auto_start') == '1' || ini_get('session.auto_start') == 'On') {

  (display error message and throw runtime exception)

}

However as an alternative a function like those for checking safe_mode setting in t3lib/utility/class.t3lib_utility_phpoptions.php could be implemented.

Actions #1

Updated by Markus Klein over 12 years ago

Since the whole Install Tool already uses t3lib_utility_phpoptions, I vote for adding a new function there.

Actions #2

Updated by Mr. Hudson over 12 years ago

  • Status changed from New to Under Review

Patch set 1 of change Icbbe4ed6afdb69642fc5a9ca3a86dc82cc066464 has been pushed to the review server.
It is available at http://review.typo3.org/6382

Actions #3

Updated by Mr. Hudson over 12 years ago

Patch set 1 of change I8a4dea14dece1d514681ed8a54f4549c22f6bf5c has been pushed to the review server.
It is available at http://review.typo3.org/6383

Actions #4

Updated by Mr. Hudson over 12 years ago

Patch set 2 of change Icbbe4ed6afdb69642fc5a9ca3a86dc82cc066464 has been pushed to the review server.
It is available at http://review.typo3.org/6382

Actions #5

Updated by Xavier Perseguers over 12 years ago

  • Status changed from Under Review to Resolved
  • Assignee set to Xavier Perseguers
  • % Done changed from 0 to 100
Actions #6

Updated by Xavier Perseguers about 12 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF