Bug #31622

Invalid query part on menu rendering

Added by Oliver Hader almost 8 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Content Rendering
Target version:
Start date:
2011-11-06
Due date:
% Done:

100%

TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Each page can have a target defined, which can also be a typeNum that gets added to the generated URL.
Now if RealURL is used, the "&type=" part will be just added to the final URL which looks like "page.html&type=1". A question mark is missing here to get a valid query part.

Associated revisions

Revision 4b6e987a (diff)
Added by Oliver Hader almost 8 years ago

[BUGFIX] Invalid query part on menu rendering

Each page can have a target defined, which can also be a
typeNum that gets added to the generated URL. Now if RealURL
is used, the "&type=" part will be just added to the final
URL which looks like "page.html&type=1". A question mark
is missing here to get a valid query part.

Change-Id: I7c8c95db7eeb80709f5a9628d56be431ce1bdd76
Fixes: #31622
Releases: 4.7, 4.6, 4.5, 4.4
Reviewed-on: http://review.typo3.org/6565
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Stefan Neufeind
Reviewed-by: Simon Schaufelberger
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

Revision 8b635401 (diff)
Added by Oliver Hader almost 8 years ago

[BUGFIX] Invalid query part on menu rendering

Each page can have a target defined, which can also be a
typeNum that gets added to the generated URL. Now if RealURL
is used, the "&type=" part will be just added to the final
URL which looks like "page.html&type=1". A question mark
is missing here to get a valid query part.

Change-Id: I8bf8a5c1bc82619db19c17dd22702371612ad339
Fixes: #31622
Releases: 4.7, 4.6, 4.5, 4.4
Reviewed-on: http://review.typo3.org/6958
Reviewed-by: Simon Schaufelberger
Tested-by: Simon Schaufelberger
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision ce5f5a78 (diff)
Added by Oliver Hader almost 8 years ago

[BUGFIX] Invalid query part on menu rendering

Each page can have a target defined, which can also be a
typeNum that gets added to the generated URL. Now if RealURL
is used, the "&type=" part will be just added to the final
URL which looks like "page.html&type=1". A question mark
is missing here to get a valid query part.

Change-Id: Idb5df6c604d12670107cbdd77c14e181cdb25dbe
Fixes: #31622
Releases: 4.7, 4.6, 4.5, 4.4
Reviewed-on: http://review.typo3.org/6959
Reviewed-by: Simon Schaufelberger
Tested-by: Simon Schaufelberger
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 1f4e1fc3 (diff)
Added by Oliver Hader almost 8 years ago

[BUGFIX] Invalid query part on menu rendering

Each page can have a target defined, which can also be a
typeNum that gets added to the generated URL. Now if RealURL
is used, the "&type=" part will be just added to the final
URL which looks like "page.html&type=1". A question mark
is missing here to get a valid query part.

Change-Id: I5404dde8963f2d5fea6a7e680cbe0f1d1f709d86
Fixes: #31622
Releases: 4.7, 4.6, 4.5, 4.4
Reviewed-on: http://review.typo3.org/6960
Reviewed-by: Stefan Neufeind
Reviewed-by: Simon Schaufelberger
Tested-by: Simon Schaufelberger
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Mr. Hudson almost 8 years ago

  • Status changed from New to Under Review

Patch set 1 of change I7c8c95db7eeb80709f5a9628d56be431ce1bdd76 has been pushed to the review server.
It is available at http://review.typo3.org/6565

#2 Updated by Oliver Hader almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF