Project

General

Profile

Actions

Bug #32340

closed

RTE HTMLArea won't load in IE if included stylesheet is empty

Added by Markus no-lastname-given about 12 years ago. Updated about 12 years ago.

Status:
Closed
Priority:
Could have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2011-12-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Environment:
TYPO3 4.5.8
htmlArea RTE 2.1.7
IE 9.0

Page TS Config:
RTE.default.contentCSS = EXT:my_rte_styles/rte.css

If the file defined as contentCSS is empty, IE9 will not finish the loading of the RTE.
In debug mode, the following log message will be repeated forever:
[HTMLArea.Iframe::getStyleSheets]: Stylesheets not yet loaded (Empty rules and imports arrays of styleSheets2). Retrying...

Although it doesn't really make sense to include an empty stylesheet, this shouldn't stop the RTE from loading.


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #32625: Custom RTE-styles brokenClosedStanislas Rolland2011-12-16

Actions
Actions #1

Updated by Stanislas Rolland about 12 years ago

  • Project changed from 1947 to TYPO3 Core
  • Assignee set to Stanislas Rolland
Actions #2

Updated by Stanislas Rolland about 12 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)
  • Target version set to 4.5.10
  • PHP Version set to 5.3
  • TYPO3 Version set to 4.5
Actions #3

Updated by Stanislas Rolland about 12 years ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF