Bug #32625

Custom RTE-styles broken

Added by Stefan Neufeind about 9 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2011-12-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Fix for #29899 broke custom HTML-styles.

Check for
file_exists(PATH_site . $fileName)
results in paths like:
/var/www/html/../fileadmin/rte.css

(which is one ../ too deep)

That path is because of the fact it was created to be used for /typo3/alt_doc.php to find it's CSS with relative URLs.

This is broken in the latest release of 4.5.9, 4.6.2 and master.

How to test:
  • Create a fileadmin/rte.css
  • Add page-TS: RTE.default.contentCSS = fileadmin/rte.css
  • Try editing content in RTE -> falls back to default.css

Related issues

Related to TYPO3 Core - Bug #29899: RTE not loading in IE when configured content css file does not existClosedStanislas Rolland2011-09-16

Actions
Has duplicate TYPO3 Core - Bug #32340: RTE HTMLArea won't load in IE if included stylesheet is emptyClosedStanislas Rolland2011-12-06

Actions
Has duplicate TYPO3 Core - Bug #32624: RTE.default.contentCSS doesnt work anymoreClosedStanislas Rolland2011-12-16

Actions
Has duplicate TYPO3 Core - Bug #32703: HTMLArea RTE is broken in 4.5.9 using IE8ClosedStanislas Rolland2011-12-19

Actions
#1

Updated by Stefan Neufeind about 9 years ago

We'd need to replace
file_exists(PATH_site . $fileName)
with
file_exists(PATH_site . 'typo3/' . $fileName)

BUT that won't work for links starting with "../" since a path of
/var/www/html/typo3/../fileadmin/rte.css
won't resolve correctly if typo3 is a symlink. (Manually removing "typo3/../" works though of course.)

Hmm ...

#2

Updated by Gerrit Code Review about 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7314

#3

Updated by Gerrit Code Review about 9 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7314

#4

Updated by Gerrit Code Review about 9 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7314

#5

Updated by Gerrit Code Review about 9 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7314

#6

Updated by Gerrit Code Review about 9 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7314

#7

Updated by Stanislas Rolland about 9 years ago

  • Assignee set to Stanislas Rolland
  • Target version set to 4.5.10
  • PHP Version set to 5.3
#8

Updated by Gerrit Code Review about 9 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7340

#9

Updated by Stanislas Rolland about 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 30 to 100
#10

Updated by Gerrit Code Review about 9 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/7341

#11

Updated by Gerrit Code Review about 9 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/7342

#12

Updated by Stanislas Rolland about 9 years ago

  • Status changed from Under Review to Resolved
#13

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF