Bug #32400

problem with save in filelist when DAM is installed

Added by Peter Kraume over 7 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
Category:
t3editor
Target version:
Start date:
2011-12-08
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

TYPO3 4.5.8
DAM 1.2.3

When DAM is installed and I try to save file in the old filelist module, I get the alert error message "An error occured while saving the data".
The file is saved anyway.

How to reproduce:
- take a TYPO3 installation where DAM is installed
- enable the old File>Filelist module
- go to File>Filelist and edit a file
- hit the save button

=> you should recieve a JavaScript alert window with the error message mentioned above

History

#1 Updated by Bas v.d. Wiel over 7 years ago

Happens here too, running 4.5.3. It also appears to invalidate my BE login.

#2 Updated by Aurélien Grayo over 7 years ago

Same problem here.
TYPO3 4.5.7, DAM 1.2.3

#3 Updated by Tobias Liebig over 7 years ago

  • Status changed from New to Rejected
  • Assignee changed from Tobias Liebig to Peter Kraume
  • % Done changed from 0 to 100

I can confirm: The problem occurs in 4.5, 4.6 and 4.7 and only if dam is installed.

I nailed down the problem and it seems to be a bug in EXT:dam.

"dam" xclasses "t3lib_extFileFunctions" in EXT:dam/binding/tce/class.tx_dam_tce_extfilefunc.php.
The original method "processData" returns and result array. However the overwritten "processData" in EXT:dam does not.

#4 Updated by Peter Kraume over 7 years ago

I've reported the issue to the DAM bug tracker:
http://bugs.typo3.org/view.php?id=18417

#6 Updated by Michael Stucki over 5 years ago

  • Project changed from t3editor to TYPO3 Core

#7 Updated by Michael Stucki over 5 years ago

  • Category set to t3editor

Also available in: Atom PDF