Project

General

Profile

Actions

Bug #32778

closed

Shortcut to 'first subpage' fails when 'move-to' placeholders are among subpages.

Added by Bart Dubelaar over 12 years ago. Updated over 9 years ago.

Status:
Rejected
Priority:
Should have
Category:
Workspaces
Target version:
Start date:
2011-12-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When a page of type shortcut points to 'first subpage' and 'move-to' placeholders are among the subpages, then a draft workspace preview throws this error: "There is no entry in the $TCA array for the table "pages". This means that the function enableFields() is called with an invalid table name as argument. "

This is because the function t3lib_pageSelect::movePlhOL calls enableFields, but the TCA is not loaded yet.

If others can confirm this bug, then how can it be fixed? Should enablefields load the TCA when not present? Or should the movePlhOL be altered so that is doesn't call enablefields?

Actions #1

Updated by Tolleiv Nietsch over 12 years ago

  • Status changed from New to Accepted
  • Assignee set to Tolleiv Nietsch
Actions #2

Updated by Bart Dubelaar over 12 years ago

I just gave it another look. I think the enableFields() check can be omitted alltogether, right? We are only interested in the permissions of the workspace version anyway, and we know there is one.

Or should there be a check on deleted=0? I suppose not, because if the original is deleted, a workspace version cannot exist.

What's your thought, Tolleiv? I will submit a patch if you agree.

Actions #3

Updated by Gerrit Code Review about 12 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9253

Actions #4

Updated by Gerrit Code Review almost 12 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9253

Actions #5

Updated by Gerrit Code Review almost 12 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9253

Actions #6

Updated by Bart Dubelaar almost 12 years ago

Steps to reproduce:

1. Create a page with one subpage and another page next to it, the latter will be moved later on.
2. Set the page type of the page with the subpage to shortcut and the shortcut mode to first subpage.
3. Open a draft workspace and move the additional page we created in step 1 into the page with the subpage.

Now preview the page with the two subpages in the draft workspace. You should see a fatal error: "There is no entry in the $TCA array for the table "pages"."

Actions #7

Updated by Gerrit Code Review about 11 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9253

Actions #8

Updated by Gerrit Code Review about 11 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9253

Actions #9

Updated by Gerrit Code Review about 11 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/9253

Actions #10

Updated by Michael Stucki over 10 years ago

  • Category changed from Bugs to Workspaces
Actions #11

Updated by Michael Stucki over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
Actions #12

Updated by Gerrit Code Review over 9 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/9253

Actions #13

Updated by Mathias Schreiber over 9 years ago

  • Target version set to 7.5
Actions #14

Updated by Nicole Cordes over 9 years ago

  • Status changed from Under Review to Rejected
  • Is Regression set to No

This problem is obsolete since TYPO3 6.2.

Actions

Also available in: Atom PDF