Bug #33625

insufficient handling of $GLOBALS['TCA'][$table]['ctrl']['versioningWS'] in class.t3lib_tcemain.php

Added by Rolf Hofmann over 10 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2012-02-02
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Setting $GLOBALS['TCA'][$table]['ctrl']['versioningWS'] = FALSE won't disable versioning because of insufficient handling in class.t3lib_tcemain.php

All occurrences of

if (isset($GLOBALS['TCA'][$table]['ctrl']['versioningWS'])) {}

should be changed to

if (isset($GLOBALS['TCA'][$table]['ctrl']['versioningWS']) && $GLOBALS['TCA'][$table]['ctrl']['versioningWS']) {}

Files

patch_20120202.diff (1005 Bytes) patch_20120202.diff Rolf Hofmann, 2012-02-02 15:20
#1

Updated by Gerrit Code Review over 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8836

#2

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/9610

#3

Updated by Tolleiv Nietsch over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF