Bug #33942

Task #33745: Integrate File Abstraction Layer

Unknown t3lib_TcaRelationService in StaticRecordCollection

Added by Oliver Hader almost 8 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2012-02-15
Due date:
% Done:

100%

TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

t3lib_collection_StaticRecordCollection::loadContents() tries to access class t3lib_TcaRelationService which is not available in the TYPO3 Core. The accordant dependent feature request was pending for master (see #32148). Since the TcaRelationService was dropped for 4.7, this fix uses plain MM queries to get the desired results.

Associated revisions

Revision fcbf817f (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Unknown t3lib_TcaRelationService in StaticRecordCollection

t3lib_collection_StaticRecordCollection::loadContents() tries to
access class t3lib_TcaRelationService which is not available in
the TYPO3 Core. The accordant dependent feature request was
pending for master (see #32148). Since the TcaRelationService
was dropped for 4.7, this fix uses plain MM queries to get the
desired results.

Change-Id: I72fa5f7dc0fcf269ef00f9ec17bff6dd5bd95173
Fixes: #33942
Releases: 6.0, 4.7
Reviewed-on: http://review.typo3.org/9028
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

Revision 3946137b (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Unknown t3lib_TcaRelationService in StaticRecordCollection

t3lib_collection_StaticRecordCollection::loadContents() tries to
access class t3lib_TcaRelationService which is not available in
the TYPO3 Core. The accordant dependent feature request was
pending for master (see #32148). Since the TcaRelationService
was dropped for 4.7, this fix uses plain MM queries to get the
desired results.

Change-Id: I72fa5f7dc0fcf269ef00f9ec17bff6dd5bd95173
Fixes: #33942
Releases: 6.0, 4.7
Reviewed-on: http://review.typo3.org/9913
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

History

#1 Updated by Gerrit Code Review almost 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9028

#2 Updated by Gerrit Code Review almost 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9028

#3 Updated by Steffen Ritter almost 8 years ago

  • Target version changed from 4.7.0-beta1 to 4.7.0-beta2

#4 Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9028

#5 Updated by Steffen Ritter over 7 years ago

  • Target version changed from 4.7.0-beta2 to 4.7.0-beta3

#6 Updated by Gerrit Code Review over 7 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9028

#7 Updated by Gerrit Code Review over 7 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9028

#8 Updated by Gerrit Code Review over 7 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9028

#9 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/9913

#10 Updated by Oliver Hader over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF