Bug #34465

Extensions can no longer be installed globally

Added by gert redlich about 10 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2012-03-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

If I enable "global installation" of extensions inside the Install Tool,
[allowGlobalInstall] yes
it has no funktion within the ext-manager.

Using "Upload extension file directly (.t3x)"
there is no global selection inside the selct box. (local install only)

OTHER: TYPO3_VERSION: 4.6.4
OTHER: PHP_VERSION : 5.3.8

#1

Updated by Jigal van Hemert about 10 years ago

  • Status changed from New to Accepted
#2

Updated by Jigal van Hemert about 10 years ago

So far I can only find that it is hardcoded in sysext/em/res/js/em_components.js :

///////////////////////////////////////////////////////
// Stores
///////////////////////////////////////////////////////

TYPO3.EM.LocationStore = new Ext.data.JsonStore({
fields : ['name', 'value'],
data : [ {name : 'Local (../typo3conf/ext/)', value: 'L'}
]
});

The values here should indeed be depending on the settings in localconf.php . If allowLocalInstall is disabled the Local option should also be removed, etc.

It seems that we need to add a method to tx_em_Connection_ExtDirectServer to build the list of locations and use this method for the store.

#3

Updated by Jonny no-lastname-given about 10 years ago

This is really annoying! I can't understand it...
This problem existed in v4.6.4 and is still present in 4.6.6.
It can't be that difficult to fix a missing value!?
Also I think, the drop down field in "Upload Extension [ from Computer ]" should not effect the installation process from the repository. It makes no sense and I searched 30 minutes until I found it in there :/

#4

Updated by Kay Strobach about 10 years ago

even if i hate global installs on linked sources this should be fixed

#5

Updated by Kay Strobach about 10 years ago

otherwise the global install should be simply removed from the installTool

#6

Updated by Steffen Gebert about 10 years ago

  • Assignee deleted (gert redlich)
  • Priority changed from Must have to Should have

Adding the line to em_components.js helps. So the logic itself still seems to work.

As posted by Jigal, there needs to be some AJAX endpoint to return the values of the ExtJS dropdown.

Kay, you know ExtJS - could you do that, please?

Steffen

P.S: I removed gert redlich as Assignee, as it looks like he doesn't want to fix this. So please don't assign it to you, if you're not working on a fix!

#7

Updated by Jigal van Hemert about 10 years ago

  • Assignee set to Jigal van Hemert
  • Target version set to 4.5.15
  • Complexity set to medium
#8

Updated by Chris topher almost 9 years ago

  • Subject changed from T3 4.6.4 BE - missing selection of "global" Ext. installation to Extensions can no longer be installed globally
  • Target version deleted (4.5.15)
#9

Updated by Ernesto Baschny almost 9 years ago

  • Assignee deleted (Jigal van Hemert)
  • TYPO3 Version changed from 4.6 to 4.5

As much as I understand that it might annoy people that are used to that functionality, I would expect that there are more important tasks to solve.

a) the old new-EM of 4.5 is not maintained anymore.
b) the old-old-EM is still part of 4.5 and should allow you to do this.
c) installing extensions globally is not recommended since ages anyway, there are tons of other ways of acchieving that (be it by copying the extension manually to that location through the CLI - if one really needs them there).

So I would suggest to close this issue.

#10

Updated by Jigal van Hemert almost 9 years ago

  • Status changed from Accepted to Closed

Closed after short discussion with RM of 4.5 .

Also available in: Atom PDF