Bug #34556

Nested IRRE elements are not removed

Added by Oliver Hader over 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
Start date:
2012-03-06
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Imagine a nested IRRE structure like Hotel->Offer->Price (taken form EXT:irre_tutorial) in the live workspace. Now the whole structure from the parent record including all child records is deleted on a custom workspace. Publishing the delete placeholders does not work for child records, only the parent gets removed and the children stay...

Since the parent record gets processed first, the "delete" action during publishing is forwared to all child records, but without the accordant publishing context. Thus, for removals it is now to be checked whether the record is marked to be removed and would be processed in the same publishing request, but just later.

How to test
Use the SVN Trunk version of EXT:irre_tutorial and run the 1nff/1nCSV tests (especially "areParentAndChildRecordsRemovedOnPublishingDeleteAction" test)
https://svn.typo3.org/TYPO3v4/Extensions/irre_tutorial/trunk/

Associated revisions

Revision 5fbf5127 (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Nested IRRE elements are not removed

Imagine a nested IRRE structure like Hotel->Offer->Price (taken
form EXT:irre_tutorial) in the live workspace. Now the whole
structure from the parent record including all child records is
deleted on a custom workspace. Publishing the delete placeholders
does not work for child records, only the parent gets removed and
the children stay...

Since the parent record gets processed first, the "delete" action
during publishing is forwared to all child records, but without
the accordant publishing context. Thus, for removals it is now to
be checked whether the record is marked to be removed and would
be processed in the same publishing request, but just later.

Change-Id: If5741f5354507938eb4ddbe2015112acc47bccce
Fixes: #34556
Releases: 4.5, 4.6, 4.7
Reviewed-on: http://review.typo3.org/9429
Reviewed-by: Susanne Moog
Tested-by: Susanne Moog
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

Revision 5e272e69 (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Nested IRRE elements are not removed

Imagine a nested IRRE structure like Hotel->Offer->Price (taken
form EXT:irre_tutorial) in the live workspace. Now the whole
structure from the parent record including all child records is
deleted on a custom workspace. Publishing the delete placeholders
does not work for child records, only the parent gets removed and
the children stay...

Since the parent record gets processed first, the "delete" action
during publishing is forwared to all child records, but without
the accordant publishing context. Thus, for removals it is now to
be checked whether the record is marked to be removed and would
be processed in the same publishing request, but just later.

Change-Id: If5741f5354507938eb4ddbe2015112acc47bccce
Fixes: #34556
Releases: 4.5, 4.6, 4.7
Reviewed-on: http://review.typo3.org/9446
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 3250c609 (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Nested IRRE elements are not removed

Imagine a nested IRRE structure like Hotel->Offer->Price (taken
form EXT:irre_tutorial) in the live workspace. Now the whole
structure from the parent record including all child records is
deleted on a custom workspace. Publishing the delete placeholders
does not work for child records, only the parent gets removed and
the children stay...

Since the parent record gets processed first, the "delete" action
during publishing is forwared to all child records, but without
the accordant publishing context. Thus, for removals it is now to
be checked whether the record is marked to be removed and would
be processed in the same publishing request, but just later.

Change-Id: If5741f5354507938eb4ddbe2015112acc47bccce
Fixes: #34556
Releases: 4.5, 4.6, 4.7
Reviewed-on: http://review.typo3.org/9447
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Gerrit Code Review over 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch 4.5 has been pushed to the review server.
It is available at http://review.typo3.org/9429

#2 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch 4.5 has been pushed to the review server.
It is available at http://review.typo3.org/9429

#3 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch 4.6 has been pushed to the review server.
It is available at http://review.typo3.org/9446

#4 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9447

#5 Updated by Oliver Hader over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Released in TYPO3 4.5.13, 4.6.6 and 4.7-beta2

#6 Updated by Michael Stucki almost 6 years ago

  • Category changed from Bugs to Workspaces

#7 Updated by Michael Stucki almost 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

#8 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF