Bug #35165

Version record array is sorted twice

Added by Oliver Hader over 7 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
Start date:
2012-03-22
Due date:
% Done:

100%

TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since the version record array will be sorted anyways, it's not required to cache the sorted state.

Associated revisions

Revision e427cc44 (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Version record array is sorted twice

Since the version record array will be sorted anyways,
it's not required to cache the sorted state.

Change-Id: Ib730b42df14c5a13790b16bfacb727304c70da38
Fixes: #35165
Releases: 4.5, 4.6, 4.7, 6.0
Reviewed-on: http://review.typo3.org/9824
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 2408df5b (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Version record array is sorted twice

Since the version record array will be sorted anyways,
it's not required to cache the sorted state.

Change-Id: Ia7495855965ce82feb3920e5f7e9725ff43b844f
Fixes: #35165
Releases: 4.5, 4.6, 4.7, 6.0
Reviewed-on: http://review.typo3.org/9927
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 5a4acabf (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Version record array is sorted twice

Since the version record array will be sorted anyways,
it's not required to cache the sorted state.

Change-Id: I68a4d8ab85a5562df5a2f33ed1c1c2d0e0d0da06
Fixes: #35165
Releases: 4.5, 4.6, 4.7, 6.0
Reviewed-on: http://review.typo3.org/9928
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 6ea0b401 (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Version record array is sorted twice

Since the version record array will be sorted anyways,
it's not required to cache the sorted state.

Change-Id: I996379ab5cf5b0fdc3ef3315a2fc1eecd24ccfbc
Fixes: #35165
Releases: 4.5, 4.6, 4.7, 6.0
Reviewed-on: http://review.typo3.org/9929
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9824

#2 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9824

#3 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch workspaces_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/9927

#4 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch 4.6 has been pushed to the review server.
It is available at http://review.typo3.org/9928

#5 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch 4.5 has been pushed to the review server.
It is available at http://review.typo3.org/9929

#6 Updated by Oliver Hader over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
  • PHP Version set to 5.3

#7 Updated by Oliver Hader over 7 years ago

  • Target version changed from 4.7.0-beta3 to 4.5.14

#8 Updated by Michael Stucki almost 6 years ago

  • Category changed from Bugs to Workspaces

#9 Updated by Michael Stucki almost 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

#10 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF