Project

General

Profile

Actions

Bug #35356

closed

Paste as plain text doesn't work in Safari (Mac only)

Added by Falk no-lastname-given over 12 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2012-03-29
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Under MacOSX with Safari the plain-text plugin is not working and shows the folling error: "Content could not be pasted as plain text because permission to access the clipboard was denied".

MacOSX 10.7.3
Safari 5.1.3

Actions #1

Updated by Stanislas Rolland about 12 years ago

  • Assignee set to Stanislas Rolland
  • Target version set to 4.5.18
  • PHP Version set to 5.3

Does it work in Google Chrome on Mac?

Actions #2

Updated by Claudia Höhne about 12 years ago

Same problem here in Safari, but works in Google Chrome...

Actions #3

Updated by Falk no-lastname-given about 12 years ago

Sorry for my late response ... Google Chrome works and only Safari has this problem.

Actions #4

Updated by Gerrit Code Review almost 12 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/15498

Actions #5

Updated by Stanislas Rolland almost 12 years ago

Please test this change: http://review.typo3.org/15498

You should clear the RTE cache, using the BE Clear cache menu, after applying the patch.

Actions #6

Updated by Falk no-lastname-given almost 12 years ago

Sorry, I've no chance to test it in Safari 5. I can only test it in Safari 6 (it's a cutomers Mac) and it seems that in Safari 6 the reported bug does'nt exist anymore. But your Patch definitely works also with Safari 6 and Chrome.

I hope anybody else can test your patch with Safari 5.

Thanks for your work Stanislas.

Greetz Falk

Actions #7

Updated by Stanislas Rolland almost 12 years ago

Falk wrote:

Sorry, I've no chance to test it in Safari 5. I can only test it in Safari 6 (it's a cutomers Mac) and it seems that in Safari 6 the reported bug does'nt exist anymore. But your Patch definitely works also with Safari 6 and Chrome.

I hope anybody else can test your patch with Safari 5.

Thanks for testing. I think that if this works in Safari 6, it will work also in Safari 5. I cannot test on Mac, and Safari dropped support for Windows, but it does work in Safari 5 under Windows 7.

Actions #8

Updated by Gerrit Code Review almost 12 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/15626

Actions #9

Updated by Stanislas Rolland almost 12 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #10

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF