Bug #37912

Content and page translations (at least) disappear when publishing workspace verion of page

Added by Lienhart Woitok over 8 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-06-11
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In TYPO3 4.7, some parts of the code responsible for page and branch type versioning have been removed. Unfortunately, in some places the code for page and branch versions is still in place (e.g. in the list module and worse, when publishing a workspace version of a page). This leads to the content and page translations and probably records from other tables with versioning_followPages set to disappear (in some cases I observed even hard deletes from the database, i.e. page translations have been lost completely!).

According to install tool of 4.6 element type versioing is the only supported versioing nowadays. Further, the column t3ver_swapmode is defined to hold the current versioning type of the page (according to the documentation of TCA (ctrl->versioningWS). Therefore, this column has no real use anymore and should probably not be used anymore. However, it is. In 4.7.1, there are 39 occurrences of the string "t3ver_swapmode" and and quite a lot of these in ifs. The problem here is, t3ver_swapmode is not set anymore when a version of a page is created and defaults to 0. 0 means page type versioning, which is not supported anymore when creating versions of a page. Thus, an inconsistent state is created.

As an easy fix for now it could be sufficient to just hardcode t3ver_swapmode to -1 when creating a version of a page. Though I might have missed something here, for me it works for now.


Related issues

Related to TYPO3 Core - Bug #38608: Remove t3ver_swapmode code blocks Closed 2012-07-03

History

#1 Updated by Wouter Wolters about 7 years ago

  • Status changed from New to Closed

t3ver_swapmode is not in the core anymore since 4.7. Closed.

Also available in: Atom PDF