Bug #38608

Remove t3ver_swapmode code blocks

Added by Oliver Hader over 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2012-07-03
Due date:
% Done:

100%

TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The different ways of versioning (element, page, branch) have
been defined to element versioning some TYPO3 version ago. With
TYPO3 4.7, those settings, especially the handling of the field
t3ver_swapmode has been removed from t3lib_TCEmain.

Since the default value of t3ver_swapmode is not -1 anymore,
but 0 instead, this will lead to inconsistent side-effects.

The solution is to remove all occurrences.


Related issues

Related to TYPO3 Core - Bug #38063: Content elements disappear on publishing a page Closed 2012-06-15
Related to TYPO3 Core - Bug #38607: Remove t3ver_swapmode code blocks Closed 2012-07-03
Related to TYPO3 Core - Bug #37912: Content and page translations (at least) disappear when publishing workspace verion of page Closed 2012-06-11

Associated revisions

Revision cebcc3c2 (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Remove t3ver_swapmode code blocks

The different ways of versioning (element, page, branch) have
been defined to element versioning some TYPO3 version ago. With
TYPO3 4.7, those settings, especially the handling of the field
t3ver_swapmode has been removed from t3lib_TCEmain.

Since the default value of t3ver_swapmode is not -1 anymore,
but 0 instead, this will lead to inconsistent side-effects.

The solution is to remove all occurrences.

Change-Id: I13053d38ce6f2c9c65335e3f648c303198d96d9c
Fixes: #38608
Releases: 6.0, 4.7
Reviewed-on: http://review.typo3.org/12551
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 918ec93b (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Remove t3ver_swapmode code blocks

The different ways of versioning (element, page, branch) have
been defined to element versioning some TYPO3 version ago. With
TYPO3 4.7, those settings, especially the handling of the field
t3ver_swapmode has been removed from t3lib_TCEmain.

Since the default value of t3ver_swapmode is not -1 anymore,
but 0 instead, this will lead to inconsistent side-effects.

The solution is to remove all occurrences.

Change-Id: Ie729287cac07d6e5d3d88a23d1291f4d701b8ea4
Fixes: #38608
Releases: 6.0, 4.7
Reviewed-on: http://review.typo3.org/12553
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision af23903a (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Remove t3ver_swapmode code blocks

The different ways of versioning (element, page, branch) have
been defined to element versioning some TYPO3 version ago. With
TYPO3 4.7, those settings, especially the handling of the field
t3ver_swapmode has been removed from t3lib_TCEmain.

Since the default value of t3ver_swapmode is not -1 anymore,
but 0 instead, this will lead to inconsistent side-effects.

The solution is to remove all occurrences.

Change-Id: Ie729287cac07d6e5d3d88a23d1291f4d701b8ea4
Fixes: #38608
Releases: 6.0, 4.7
Reviewed-on: http://review.typo3.org/12553
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/12551

#2 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12553

#3 Updated by Oliver Hader over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Vladimir Podkovanov about 7 years ago

Just for note - this revision brokes templavoila, because field "t3ver_swapmode" is hardcoded in class.tx_templavoila_api.php and this causes SQL error.

#5 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF